Community Forum

"Audio Setup" won't let me change from Spanish to English

New Poster

"Audio Setup" won't let me change from Spanish to English

A few days ago most of the audio on my channels switched to Spanish.  I searched the Help Forums and see it's a common issue. 

 

I've now gone to Menu > Setup > Audio Setup.

 

"Espanol" IS now the default language.  The top of the screen says "Select your audio track.  Press < > to change settings."  the problem is, though, that when I hit either < or >, it does not work to change the language option.  I can scroll through the rest of the list without issue.

Diamond Problem Solver

Re: "Audio Setup" won't let me change from Spanish to English

Most audio issues are covered at this sticky.

 

http://forums.xfinity.com/t5/XfinityTV-and-Equipment/Spanish-Audio-No-Audio-DVS-SAP-Secondary-Audio-...

 

If this doesn't help, then it would be best to call Comcast support at 1-800-266-2278.

New Poster

Re: "Audio Setup" won't let me change from Spanish to English

EASY FIX:
DVR > Menu > Setup > Audio Setup > Descriptive Video Service > OFF
Contributor

Re: "Audio Setup" won't let me change from Spanish to English

This "sticky" says that the language setting on the cable box may have been accidentally changed.   Well, that was done by Comcast.  Have you seen how many complaints there are about this problem?   Comcast needs to accidentally change it back.

New Poster

Re: "Audio Setup" won't let me change from Spanish to English

I'm having the same issue and am very frustrated.  Trying to watch NFL and I don't speak Spanish!  The menu/audio settings only have one default choice - Spanish.

Regular Contributor

Re: "Audio Setup" won't let me change from Spanish to English

You need to turn off Second Audio Program (SAP).

 

I think one of the colored remote buttons does it, but I'm not sure which one.

 

You should also be able to do it from the menu.

 

-KP

New Poster

Re: "Audio Setup" won't let me change from Spanish to English

Thanks, Jeepers1920!  This did the trick, allowing the default language to be changed.

New Poster

Re: "Audio Setup" won't let me change from Spanish to English

Go back into the Audio Settings and turn Descriptive Video Service OFF.  When you do, it will allow you to change the Default Audio Track.

New Poster

Re: "Audio Setup" won't let me change from Spanish to English

Great & Thanks!

New Poster

Re: "Audio Setup" won't let me change from Spanish to English

Thanks jeepers1920, you are the man.    Your solution worked...

New Poster

Re: "Audio Setup" won't let me change from Spanish to English

Thank you

 ! Turning Descriptive Video Service to off, allowed the default "Spanish" to be changed back to English!
New Poster

Re: "Audio Setup" won't let me change from Spanish to English

Changing the descriptive video service worked for me!  THANK YOU!  

New Poster

Re: "Audio Setup" won't let me change from Spanish to English

I don't have a setup option under menu...???
Regular Contributor

Re: "Audio Setup" won't let me change from Spanish to English

It's probably SAP, not Audio Setup.

 

-KP

New Poster

Re: "Audio Setup" won't let me change from Spanish to English

K, how do I fix that cause I'm not seeing an option for that anywhere either.
Regular Contributor

Re: "Audio Setup" won't let me change from Spanish to English

Since I have no idea which cable box you're using, I can't tell you, but Google is your friend.

 

Also, commonly one of the color buttons will change that.

 

-KP