Community Forum

RNG110 Unresponsive

New Poster

RNG110 Unresponsive

Twice now, (a week ago and yesterday) my RNG110 cable box has randomly shut off, and become unresponsive to the controller.  There is no picture on the TV (a no signal box bounces around the screen) and the Remote, HD, and Data lights stay on constantly while the power light remains off.  Last time this occured the box randomly started working again.  However this time it has not.  I have tried unplugging the box and tried removing the cable and HDMI cord from the back of the box.  I have tried leaving the box unplugged for multiple hours. Nothing seems to work. I feel as though my only option is to return the box, that must be faulty.

Diamond Problem Solver

Re: RNG110 Unresponsive

Double check that the power adapter is 5 volts, and that they didn't give you a 12 volt adapter by mistake.  It has happened in the past causing all kinds of erratic issues on the RNG110's.

New Poster

Re: RNG110 Unresponsive

It says Input of 120V and Output of 5V. So I assume that's not the problem.

Diamond Problem Solver

Re: RNG110 Unresponsive

Swap the box, take the remote with to the local Comcast office.

New Poster

Re: RNG110 Unresponsive

UPDATE - After consulting the user manual online, I found that the unit will turn off and you need to use your remote to run it on.  There is no on button...only via remote.  I tried several times and it finally went on. Funny that Xfinity technical support could not trouble shoot this yesterday before I returned the box.

 

This is my second RNG110 and right out of the box the lights cycle and flash once you plug in and then they all go off and the box is unresponsive. No power light.  I tried to plug in my kitchen electrical outlet and another electric and cable outlet in another room.  No differrence even without a cable hooked up.  The first box lasted 1 week.  I did get a strange error message on my TV but now cant get it to repeat.  It said something about the equipment being incompatible with the cable service.   Frustrating as this means another trip to the Comcast office.

Contributor

Re: RNG110 Unresponsive

I'm getting the same problem except my RNG110's Power led is on and nothing else. If I plug my cable directly into my TV, I was able to receive the local channels (and phone and internet connection)so it's not the signal or the cable modem. I called Comcast CS and they tried sending a signal to my box but it didn't respond.  I went to the local Comcast office and swapped out the box and, initially, I get a signal on only channel 1. After a few hours, it exhibits the same symptom as the previous one (power LED on only, no signal to TV). After a few more hours, it magically cleared itself and now is behaving normally.

New Poster

Re: RNG110 Unresponsive

Thank you so much! the user manual with the Xfinity remote control did the trick!