Community Forum

No picture or sound but the guide works

New Poster

No picture or sound but the guide works

My internet works fine as do 4 of the 5 TVs in the house with cable. One Cable box just stopped delivering picture and sound yesterday. The guide displays just fine, but thats it. We were told to unplug and replug in the box yesterday by a rep. That did not work and the phone reps dont seem to want to really help. Can someone please help?
New Poster

Re: No picture or sound but the guide works

I am having the same problem with my XFinity Box.  My PC with Mediaca Center and a tuner card works fine.  Was an update rolled out that broke the XFinity box?

New Poster

Re: No picture or sound but the guide works

I had a similar problem. Woke up and screen was grey, sound was playing with no picture. Remote didn't work. Read the post, Unplugged and allowed to reboot. Everything works fine now.

New Poster

Re: No picture or sound but the guide works

No picture or sound but the guide works then talked to asomeone I could not even understand and when all was said and done they say its going to take 5 days to get a technition out to change the hd box unacceptable I will be going back to direct tv . very poor service?

New Poster

Re: No picture or sound but the guide works

I rebooted several times and still only get the station display logo  but no live signal.  I do get everything on my Media Center PC so I know my cable is working.  I talked to an Xfinity X1 online supprt person and they could not help me.  Now I am will be waiting up to 3 days to get a call from the next level support.

New Poster

Re: No picture or sound but the guide works

No help here but I have the same problem.  I unplugged & had signals sent multiple times, went and exchanged my box for a new one, and still I have the same problem, even with the new box.  The guide works but everytime I try to watch a channel I get the error measage:

 

         One Moment Please

This channel should be available shortly.

 

The people I talked to have been courteous,polite,  but ultimately ineffective.  I now have to wait for a service call.  You would think with this happening to other people Comcast would know what the problem is and update their call centers with useful information.

 

Comcast, figure this out please.

 

 

 

Frequent Visitor

Re: No picture or sound but the guide works

I had the One Moment Please message a few weeks ago.  When I called for support they had me umplug and reset the DVR box.  That did not help although we tried it several times.  The person told me to go get a new box which I was very reluctant to do since going to the local store is a bad experience.  I read online that it's a signal problem not  a box problem.  I called again to get a technician out and it turned out we had some bad wiring that was replaced.  Problem was solved.  Get a technician out to fix the problem.  Get the insurance so you don't have to pay extra.  Even though I've solved that problem I now have a new problem with my picture disappearing randomly.  Frustrating.

New Poster

Re: No picture or sound but the guide works

Same problem. Did anyone find a way to resolve this?
Official Employee
Moved:

Re: No picture or sound but the guide works