Community Forum

No Signal

New Poster

No Signal

When I turn on my TV with the input set to "xfinity", I get "no signal". I have a motorola box, which I leave powered on, due to issues with recording shows, if it's tuned off. In order to get connected to xfinity, I must unplug the cable box & plug it back in. Then it reboots & the signal is ok. Please advise.

Official Employee

Re: No Signal


@JimPgh wrote:

When I turn on my TV with the input set to "xfinity", I get "no signal". I have a motorola box, which I leave powered on, due to issues with recording shows, if it's tuned off. In order to get connected to xfinity, I must unplug the cable box & plug it back in. Then it reboots & the signal is ok. Please advise.


No signal usually means that the TV set is on the incorrect video input.

Check to see how your cable box is connected to the TV set.

If connected via RF-coaxial cable, the TV should be on channel 3 or 4.

If connected via HDMI be sure that HDMI is selected on your TV set (there may be an HDMI 2, HDMI 3, etc. input on your TV set, check them all).

If you have X1, be sure that you are connected to the HDMI output on the X1 cable box.

If you are connected via component cables (red, blue, green) be sure that your Component is selected as the input on your TV set

If your TV is connected via composite cables, (red, white and yellow) check that your TV is selected to Video or Game .

Also be sure that your cable box is turned on.


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!