Community Forum

How to turn off Xfinity narration on programs

New Poster

How to turn off Xfinity narration on programs

There is a narrated explaining what the actors are doing?  How do you get rid of this?

Bronze Problem Solver

Re: narration on programs

Check the status of "SAP", Second Audio Program on your system and change it.

New Poster

Re: narration on programs

this has been happening to me for the past teo nights but only with abc prime time shows.

 

i would think if it was related to SAP, it would be happening on multiple channels and at all times of day.

 

just to be sure, i checked the comcast audio settings (in menu-setuo-audio) and "descriptive video service" is off.

 

help!

Frequent Visitor

Re: narration on programs

 

I don't even have that option and it happened to me last night for the first time.  The only thing close is "Default Audio Track" (I think that's what it says) and it's set to "Channel Default"..  I don't have an option for Descriptive Video Service...

 

 

Silver Problem Solver

Re: narration on programs

In the cable box menus look for the Default Language under Audio setup. Also on the TV look for a button on the TV remote that controls the SAP function (on my tv it is labeled MTS). Sometimes cycling through the TV settings for SAP fixes a problem like this.

 

Official Employee

Re: narration on programs

Video Descriptions are supplied by programming providers combined with the regular program audio on a separate audio track. Where a programming provider does supply Video Description in a Comcast System, Comcast will pass-through Video Descriptions on the secondary audio channel (sometimes also used for Spanish programming). 

To access the separate audio track that contains Video Description, you would need to select the secondary (usually "Spanish") audio language on the cable box. 

 

 

Press the Menu button twice on the Comcast Universal Remote Control. (The Menu button is the red oval-shaped button located to the right of the center of the remote - find the right-facing arrow button and move your thumb to the right and then down.)

 

A new screen below will appear, with the top-left option automatically selected.Use the down-arrow key (above the Info button) to navigate to Setup and press OK/Select (the center key on the remote control in the middle of the 4 arrow/directional buttons).

Use the down-arrow key (above the Info button) to navigate to Audio setup and press OK/Select.

 

The Default Audio Track will default to the first optionChannel defaultwhich which is always the channel’s main audio track (unless it was previously changed). 

  • Press the right-arrow navigation key to change the audio track.  Changing this selection will instantly change the audio.
    1. Press once for English
    2. Press twice for Spanish (Español) OR to activate Video Description (DVS)
    3. Press three times for French (Français)
    4. Press four times for Portuguese (Portugues).
    5. Then press the Exit button (above the Volume button) to resume program viewing

Please note: These audio options can only be heard if the program provider or cable channel is providing that additional audio option.

 

 

If the above does not help, try as others have said  - look at the remote control for your TV set (not your cable box) as the language settings may have been accidentally changed  (sometimes labeled as MTS or SAP).   

Official Employee
Moved:

Re: narration on programs

New Poster

Re: narration on programs

That Was It. Go To Your SAP and Change To English (ENG). I Must Have Accidentally Switches It Popping Through Channels

Thanks!
New Poster

Re: narration on programs

re:  narrative on programs.   We have been dealing with this for two weeks.  Followed your instructions and its fixed.  Kudos to you.  Thanks.