Community Forum

Cable box won't turn on

New Poster

Cable box won't turn on

We got cable and Internet. The internet is working fine, but my cable box won't turn on. I think everything is plugged in right. I know the power cord is plugged in right, and it's plugged into an outlet that works! 😊 Still, no lights on the cable box. It's a xfinity rgn110. I've tried using the provided xfinity remote...won't turn the box on. It turns my tv on and off but not the cable box. Tried unplugging and re plugging everything. Tried tuning my tv to the hdmi port that I have it plugged into. It says no signal...not sure what I'm doing wrong. I'm not very techy, but I can't find an answer on online... ☹️
Silver Problem Solver

Re: Cable box won't turn on


Debrahjill wrote:
We got cable and Internet. The internet is working fine, but my cable box won't turn on. I think everything is plugged in right. I know the power cord is plugged in right, and it's plugged into an outlet that works! 😊 Still, no lights on the cable box. It's a xfinity rgn110. I've tried using the provided xfinity remote...won't turn the box on. It turns my tv on and off but not the cable box. Tried unplugging and re plugging everything. Tried tuning my tv to the hdmi port that I have it plugged into. It says no signal...not sure what I'm doing wrong. I'm not very techy, but I can't find an answer on online... ☹️

Do you have the X1 system?


I am not a Comcast employee; I am just a customer, volunteering my time to help other customers here in the Forums.
New Poster

Re: Cable box won't turn on

I have no idea. I attached a picture of the cable box
IMG_7073.JPG
Official Employee

Re: Cable box won't turn on


Debrahjill wrote:
I have no idea. I attached a picture of the cable box

You either got a bad box or bad power supply, if you can't get lights. Swap them out.