Community Forum

Cable box not working with data light flashing

New Poster

Cable box not working with data light flashing

I hooked up my cable box and had the "to be announced" banner where the show information would normally be and after activating the equipment online, the screen went black and the data light has been flashing ever since. Box turns on but nothing shows on the screen. Unplugged it for 1 minute after about 2 hours and then plugged it in with no change. Just a black screen with the data light flashing, no menus or anything. Checked all my connections. The coax cable is running from a splitter that the modem is also attached to. Internet is working fine.
Thanks for the help.
New Poster

Re: Cable box not working with data light flashing

Did you ever get this resolved? I’m having the same issue.
Expert

Re: Cable box not working with data light flashing


@Csg2020 wrote:
I hooked up my cable box and had the "to be announced" banner where the show information would normally be and after activating the equipment online, the screen went black and the data light has been flashing ever since. Box turns on but nothing shows on the screen. Unplugged it for 1 minute after about 2 hours and then plugged it in with no change. Just a black screen with the data light flashing, no menus or anything. Checked all my connections. The coax cable is running from a splitter that the modem is also attached to. Internet is working fine.
Thanks for the help.

Sometimes "Activating" on line can fail. In those cases I call the Comcast number supplied with your "self install" kit. They will most likely ask to to unplug the box about 2 minutes and plug it back in to reset the box. They will resend the signal and wait on their end until you get restarted correctly, or help out if needed.