Xfinity plant
Community Forum
Xfinity globe

xfi

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

New Poster

xfi

I installed the new modem that was sent to me this week that was required for xFi and activated it manually.  Now when I download the xFi app it asks me to activate it and I don't want to mess up my working modem.  Is the activation just for the app?  If not, how do I get out of the startup area of the app.

 

Thank You

New Poster

Re: xfi

Also on my  account it says setup  75% complete.  It says Complete 1 step to finish your account setup with no inidication what I should do.

Expert

Re: xfi

Check your email for a message from Comcast.

Official Employee

Re: xfi

Hi joanvn, the in-app activation is for the Gateway and should enable xFi once completed. If you have already activated your Gateway through another method, you can still run through the activation in the xFi app without negatively impacting your service.

The activation steps in the app will prompt you to personalize your network name and password, so if you activated it using the device's default name and password then this step will kick off any devices connected to the network. If you have already personalized, then you can use the same name/password.

If you experience issues with this, or still receive the upgrade message in xFi after completing the activation, please let us know and we can look into it further.