Community Forum

can't log into mail on any browser using Windows 10

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

New Poster

Re: can't log into mail on any browser using Windows 10

I still cannot access email using Edge or Explorer ...... I can access using Chrome ..... although I don't like Chrome, it is better than nothing.

Frequent Visitor

Re: can't log into mail on any browser using Windows 10

I've downloaded and installed some Dell updates for my laptop.....particularly for the Intel network and wireless cards.  After the reboot I was able to log into my Comcast mail using Chrome......I will check the other browsers after I have read my mail.  I was still getting a browser out of date issue with Edge.  But at least I can finally log in to get my mail and manage my Xfinity account.

Frequent Visitor

Re: can't log into mail on any browser using Windows 10

Yes.....and I just updated Chrome to the latest and it still won't work.   When I open Edge or IE to the Xfinity log in page, I also get a "Browser out of date" error which I cannot do anything about because I am running the latest versions of both browsers.  Is there some setting in the Registry that I can tweak that might take care of this and perhaps then I can log in?

Expert

Re: can't log into mail on any browser using Windows 10

I have a Dell Inspiron Windows 10, and I'm not having this issue.  Are you running the most recent iterations of those browsers?  Have you tried clearing browsing history?

Frequent Visitor

can't log into mail on any browser using Windows 10

I am unable to log into Comcast mail using any browswer on a Dell laptop running  Windows 10....this problem occured within the last week.  I've tried IE 11 (get message that it's out of date), Firefox and Chrome....none of them work.  I get an authentication error.  However, on my desktop and phone I am having no problem.  Any suggestions?