Xfinity plant
Community Forum
Xfinity globe

Xfinity XFi App not working

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Regular Visitor

Xfinity XFi App not working

My app is not working, keeps asking me to upgrade. Also my internet speeds are nothing close to what I pay for since I switched to the new modem
Regular Visitor

Re: Xfinity XFi App not working

I'm getitng the same thing with my Arris SBG6580.  It sounds like XFi is only supported on these 3 cable modems:

   Arris 1682G

   Cisco 3941T

   Arris TG3482G

 

Which as far as I know... none of those are approved for resale.  So XFi is limited to rental devices only... not that Xfinity will admit to that.

 

If you know of any approved cable modem that can be purchased and works with XFi, I would love to hear about it.

Official Employee

Re: Xfinity XFi App not working

Hi Mcswaink! I can confirm whether or not your modem is compatible with the XFi app and help troubleshoot, as well as look into your speed issues, even discuss your billing. Please send me a private message verifying the first and last name of the account holder, and the street address associated with your services. To send a private message click on my name "ComcastChe", then click private message me.