Xfinity plant
Xfinity globe
Community Forum

Xfi does not work “upgrade equipment”

New Poster

Xfi does not work “upgrade equipment”

I recently received a message from xfinity stating I was eligible for a green modem upgrade to use the new xfi platform. I ordered the modem, installed, and setup my new WiFi but I cannot access the xfi platform! It consistently states I need to upgrade my equipment, which I have! Spoke to two different xfinity operators who could not solve the issue and three days ago told me they would work on it and call me when fixed! Haven’t heard back and the system still gives me the upgrade error message! Very frustrated with this as I was excited to try the new platform and have had not prior problems with xfinity in the years I have been a customer! Any suggestions?

Accepted Solutions
Official Employee

Re: Xfi does not work “upgrade equipment”

Glad to hear we were able to get you up and running. Please feel free to post again if you have any other needs.

 

Thank you for choosing Comcast and using the Forums!


All Replies
Official Employee

Re: Xfi does not work “upgrade equipment”

Hello J_Henry. I can help get your xFi system running. Please send me a private message and include your full name, service address, and account number so I can assist you. 

Official Employee

Re: Xfi does not work “upgrade equipment”

Glad to hear we were able to get you up and running. Please feel free to post again if you have any other needs.

 

Thank you for choosing Comcast and using the Forums!