Xfinity plant
Community Forum
Xfinity globe

Webmail Page will not load

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Frequent Visitor

Webmail Page will not load

Hi-

 

I was given a new Win 10 laptop at work, and have NOT been able to load webmail using IE11 since.

I've always used comcast.net, and then click the mail icon, and it would open a 2nd window to login and I'd get my webmail.

 

Lately I've seen the autodirect to this url http://my.xfinity.com/?cid=cust, and I get the mail icon(envelope) at top and click it.

I would get this https://connect.xfinity.com/appsuite/ with many characters after the final forward slash, then the characters would disappear leaving me with only the pound symbol # after the slash and Webmail will never load only showing 3 dots moving- attempting to access. Out IT guy allowed all the JS options to be enabled- as it looks like Java was hanging.

Any ideas?

 

I have tried Firefox- and it works fine even though the page looks huge.

 

Thank You-

Expert

Re: Webmail Page will not load


Try clearing out your cache/browsing history in IE-11. When you have done that, close it out and re-start it in a fresh session. 

Frequent Visitor

Re: Webmail Page will not load

Negative- this is on a brand new installation. After a week we reset IE11.After thinking it was something we script on our networking at work- I tried my laptop at home through my own wifi- and same result. I also have the issue with Chrome.

Someone thought it might be a Java issue- clicking mail icon at top right of Xfinity page pops open a new window for me to log in- which I do, and I can see the url in window show some variation of this:

https://connect.xfinity.com/appsuite/#

after the # sign-it will show a number of other characters after it and after 5 or 10 seconds- only the above url will show. The actual window itself defaults to white with 3 search dots.

 

Its probably something in our default load of Win 10 and Java.

 

Thx

Chris