Community Forum

Unable to connect to xfinity WiFi hotspot sinxe changing modems

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

New Poster

Unable to connect to xfinity WiFi hotspot sinxe changing modems

A service tech swapped out my arris modem for another one. Since then I've been unable to connect to xfinitywifi from all devices. I was able to connect before then. Dealt with support for days had another technician come out and they have no idea of the problem. Modem has been reset, insured hotspot was enabled in the account and on the back end, and still no luck. When I brought home a new laptop that has never had access to my Wi-Fi or XFINITY hotspot, it connected and took me to the login screen with no issue. Anyone have any suggestions?
Expert

Re: Unable to connect to xfinity WiFi hotspot sinxe changing modems

Humm that's weird. Try:

 

  1. Forget the network on your device.
  2. Restart the device.
  3. Reconnect to the network as if it was new.

I am not an employee.
Silver Problem Solver

Re: Unable to connect to xfinity WiFi hotspot sinxe changing modems

FWIW: I'm having the same problem, I have three devices that will connect to xfinitywifi hotspots in my home. Now they connect to the hotspot, but there is no internet. I've forgotten the connection, connected to the home private network It's fine.

 

The xfinitywifi signal is strong, but no internet. I even tried deleting a device from my devices that connect to xfinitywifi in my account, didn't help. I would have expected a browser to come up requesting the userID and password when trying to reconnect that device but it didn't happen.

 

EDIT: whatever the problem was with the hotspots, it's now fixed for me at least, after a couple days of being down.

New Poster

Re: Unable to connect to xfinity WiFi hotspot sinxe changing modems

Same here. I've forgotten the networks rebooted and still doesn't work. I even reset network settings. The first time i did that it worked and I connected for 10 min. Has not worked again. Even when i tried resetting network settings again m
Silver Problem Solver

Re: Unable to connect to xfinity WiFi hotspot sinxe changing modems

I can't tell whether the xfinitwifi SSID shows up in the list of available networks.  If it doesn't you can turn it on with My Account.

https://www.xfinity.com/support/articles/disable-xfinity-wifi-home-hotspot

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
New Poster

Re: Unable to connect to xfinity WiFi hotspot sinxe changing modems

I dont see the SSID option on my list. Only xfinitywifi. I have the hotspot feature enabled in my acct.
Expert

Re: Unable to connect to xfinity WiFi hotspot sinxe changing modems

Question. To clarify, are you trying to connect to your own home network's *private* WiFi broadcast signal or the xfinitywifi *public* hotspot that is also broadcast by the gateway device ?

 

The default private one looks like this: HOME-XXXX-2.4 or HOME-XXXX-5

 

XXXX = various letters and numerals.

 

The public WiFi hotspot looks like this: xfinitywifi

 

 



I am not a Comcast Employee.
I am a fellow customer, volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark the post as best answer!
New Poster

Re: Unable to connect to xfinity WiFi hotspot sinxe changing modems

 The public WiFi hotspot that states: xfinitywifi
Expert

Re: Unable to connect to xfinity WiFi hotspot sinxe changing modems

Thanks for clarifying ! I got nothing, sorry. All yours first responders..


I am not a Comcast Employee.
I am a fellow customer, volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark the post as best answer!
Silver Problem Solver

Re: Unable to connect to xfinity WiFi hotspot sinxe changing modems


@eldixo wrote:
 The public WiFi hotspot that states: xfinitywifi

What wifi device are you trying to connect to xfinitywifi?  Are you saying the device shows the xfinitywifi SSID but the device can't connect to it?

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
New Poster

Re: Unable to connect to xfinity WiFi hotspot sinxe changing modems

I'm using the same modem i had prior to it being swapped out by tech. ARRIS TG862 (TG862GCT) 343 Mbps Cable modem. The issue: I see "xfinitywifi" on my Wi-Fi list, i click and it says connecting. Then I get the error "unable to obtain IP address ". I have full Wi-Fi strength signals. I was successfully able to connect before the tech changed my modem (due to unrelated issues). All devices that were able to connect before (cell, tablet, iPhone) now have the same issue. The 2nd tech who came to address the issue was successfully able to connect . My new laptop is able to connect w/o the IP error. I have forgotten the networks, rebooted device and modem and still doesn't work.
Silver Problem Solver

Re: Unable to connect to xfinity WiFi hotspot sinxe changing modems


@eldixo wrote:
I'm using the same modem i had prior to it being swapped out by tech. ARRIS TG862 (TG862GCT) 343 Mbps Cable modem. The issue: I see "xfinitywifi" on my Wi-Fi list, i click and it says connecting. Then I get the error "unable to obtain IP address ". I have full Wi-Fi strength signals. I was successfully able to connect before the tech changed my modem (due to unrelated issues). All devices that were able to connect before (cell, tablet, iPhone) now have the same issue. The 2nd tech who came to address the issue was successfully able to connect . My new laptop is able to connect w/o the IP error. I have forgotten the networks, rebooted device and modem and still doesn't work.

Are you using separate names for your SSID's (2.4 and 5)?

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
New Poster

Re: Unable to connect to xfinity WiFi hotspot sinxe changing modems

Only have one for my home "HomeWifi" which was named something else before modem swap. I believe we had 2 networks for home before too
Screenshot_20180415-094428.png
Silver Problem Solver

Re: Unable to connect to xfinity WiFi hotspot sinxe changing modems

It's a difficult one. I once exchanged a rental gateway with Comcast. I had the hotspot enabled in my account settings, but the hotspot failed to show for just over a week after receiving the device.

I used to use the free inSSIDer app to look at the wireless around me. I could tell if the gateways hotspot was broadcasting, because the channel would be the same as my own private network, same power and the MAC address would be 1 or 2 digits different, from the private SSID.

Could be that you are trying to connect to a hotspot that is just out of range for you.

 

(but then if your new laptop does connect, it doesn't explain why your other devices don't)...! Smiley Happy My hotspot connection probs, disappeared on their own after a few days, as I mentioned in the earlier post

Expert

Re: Unable to connect to xfinity WiFi hotspot sinxe changing modems


@RobertWy wrote:

Are you using separate names for your SSID's (2.4 and 5)?


FWIW, the 862 isn't a dual band capable device Robert.



I am not a Comcast Employee.
I am a fellow customer, volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark the post as best answer!