Community Forum

Unable to connect to my company's secured website

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Regular Visitor

Unable to connect to my company's secured website

I am hoping someone out there can help me out or steer me in the right direction.  I generally work from home at least once a week but have been unable to connect to my work's secured website.  It seems that this started after Comcast/Xfinity sent me a new modem.  I was going to reconnect my old modem to just see if that would help, but it seems odd to me that would be my problem.  This is the error message I get when trying to access.  I will also add that I am able to connect to my credit union and other secure websites.  I've tried different search engines and no luck.  I removed and reinstalled Citrix Receiver, the software that our company uses, to access work and no luck.  My IT support at work is limited on what they can do since I'm on my personal device.  Has anyone had this issue?   

Hmmm...can’t reach this page

Try this

The DNS name does not exist.

Error Code: INET_E_RESOURCE_NOT_FOUND

 

Contributor

Re: Unable to connect to my company's secured website

Try using different web browser like Firefox or Chrome to access that page you are trying to access.  Don't use  edge or explorer because the're mediocre web browsers

Regular Visitor

Re: Unable to connect to my company's secured website

I tried accessing through Chrome and I got the same error message.

Thanks for the suggestion.