Community Forum

Slow speed on newer laptop

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

New Poster

Slow speed on newer laptop

Hi,

I have just had Comcast install the new xFi gig speed modem in my home office. I have two laptops hardwired to the modem, but I'm getting two very different speeds. The older laptop purchased in 2014 is an Asus with an external net gear ac network card. On this laptop, I'm getting 920Mps hard wired which is great. On the newer laptop purchased in late 2017 is a Lenovo with a solid state HD and hardwired through an insignia USB type c gigabit to ethernet adapter, and I'm getting 510 Mbs. The Comcast tech told me there is a setting on the laptop that is stopping me from getting the higher speeds. Can anyone help?

Regular Contributor

Re: Slow speed on newer laptop

USB vs PCI... USB is usually a little bit slower.  510 though sounds like it might be in 1/2 duplex mode for some reason.

Expert

Re: Slow speed on newer laptop

FWIW, their USB adapter is just a jumper cable. There is no electronics so there is no way to toggle the duplex;

 

https://www.insigniaproducts.com/pdp/NS-PUCGE8/6058900



I am not a Comcast Employee.
I am a fellow customer, volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark the post as best answer!