Community Forum

Ring Video Doorbell Pro, Google Wifi and Arris SB6190

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Expert

Re: Ring Video Doorbell Pro, Google Wifi and Arris SB6190

Comcast pushes the firmware to your modem automatically - you can't change it yourself.


I am not a Comcast employee, just a moderator. Pls observe Wheaton's Law.
Regular Contributor

Re: Ring Video Doorbell Pro, Google Wifi and Arris SB6190

Thanks for your response. I will Google my modem and Puma. Any ideas on how to upgrade the firmware on my modem since I own it?
Expert

Re: Ring Video Doorbell Pro, Google Wifi and Arris SB6190

I have the same doorbell and I had to fiddle with network settings to get it to work properly. I moved mine to the 2.4GHz network and changed the channel on the WiFi network. I don't think this is a Comcast issue directly. Other possibilities: 

 

  • Your router needs to be upgraded
  • Your modem has some known issues (Google "SB6190 and Puma")
  • The Ring device is defective.

This might be helpful: http://forums.xfinity.com/t5/Your-Home-Network/Tips-for-Better-WiFi-Network-Performance/td-p/2627659...

 


I am not a Comcast employee, just a moderator. Pls observe Wheaton's Law.
Regular Contributor

Re: Ring Video Doorbell Pro, Google Wifi and Arris SB6190

Yes, internet works great. I don't use Netflix but watch a lot of YouTube videos with no problems.
Expert

Re: Ring Video Doorbell Pro, Google Wifi and Arris SB6190

Hi @Missy

Your internet works fine otherwise? Do you have issues streaming Netflix or videos?


I am not a Comcast employee, just a moderator. Pls observe Wheaton's Law.
Regular Contributor

Ring Video Doorbell Pro, Google Wifi and Arris SB6190

Hello!

 

I have had the Ring video doorbell pro for a while now and I cannot get it to work properly.  I have spoken with both Comcast and Ring and one sends me back to the other.  My problem is sometimes I get the black screen, sometimes I get clear video until I try to communicate with the person at my door and which point the video freezes.  

I have replaced my original router with the google wifi mesh network thinking that would fix the problem, but it didn't.  Ring tells me to contact Comcast about UDP Protocol so I do.  They tell me that there isn't anything they can do since I own the SB6190 modem.  Is there anyone out there that can help me fix this issue?  It is absolutely driving me insane@!

 

Thank you,

 

Missy O