Community Forum

Problems with home network

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Problem Solver

Problems with home network

For the last week I have been having the following problems:

1. After Windows 10 is awakened from sleep mode I can no longer connect to my network or the internet. To fix this I have to launch a Windows network repair.

2. Yesterday my wireless printer kept getting errors while trying to print. I had to give up trying to print.


I tried restarting the gateway and the computer but the problems persisted for about a week. Today it seems back to normal.

Is it possible the gateway is going bad? I have a Technicolor TC8305C.


Re: Problems with home network

Sounds like the machine is losing its IP address after it falls asleep. You could disable sleep mode in the OS. 


And anything is "possible". The TC8305C is an older XB1 model gateway. You could try having them swap it out for a newer and better performing XB3 model;

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Problem Solver

Re: Problems with home network

The problem with sleep went away after I reset the gateway. BTW, my computer is set to go to sleep after 30 minutes. I only shut it down or restart it about once a week.


Was using my blu-ray player to watch YouTube tonight. The wireless connection to my gateway dropped several times.It tooks numerous attemps each time to reconnect. They are probably only ten feet apart.


I wonder if there is interference causing problems with my WiFi.I ran a program called inSSIDer Home. It said that I had overlapping channels from neighboring networks.My WiFi channel had been set automatically to #8. I changed the channel manually to the recommended #1.