Community Forum

Primary Comcast email returning 5.1.1 Not Our Customer error, secondary accounts working as expected

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

New Poster

Primary Comcast email returning 5.1.1 Not Our Customer error, secondary accounts working as expected

I currently have a rep at our local Comcast store troubleshooting this issue, but the weirdness is such that I thought I'd throw it out into the community and see if anyone has a novel idea to pass on.


History:  bundled Performance Pro Internet with our existing Digital Starter TV service on 5-16 at our local Xfinity store, running with our own Netgear CM600 modem and a Nighthawk R7000 router. Got the connection up and running in no time, excellent responses across the board.  Email was initally fubared for both the primary account and secondary user (second email address for my hubby).  (The motivation for getting Comcast internet was to be able to jettison our increasingly inadequate and expensive Frontier DSL, and save a bit of cash in the long run.)


Web portal behavior:  via, I click on the envelope icon on the top bar, and sign in.  My browser attempts to connect to very briefly before I get a "Sorry, we couldn't find that page" error message, with options to go to the homepage or the site map. I've tried going to the site map page and clicking on Check Email under the Xfinity Connect section, but that just produces the same can't-find-the-page error message.


Thunderbird POP and IMAP behavior:  an account set up with either service consistently failed to authenticate after a long attempt to connect to the server when checking for new e-mail.  Test messages from both my current Frontier account and my Hotmail account to the primary e-mail address bounced back with (e-mail addresses redacted):

<>: host[] said: 550 5.1.1
    Not our Customer (in reply to RCPT TO command)

 And at first, similar test messages to the secondary e-mail address bounced back with:

<>: host[] said: 550 5.1.1
    <> recipient mailbox unallocated (in reply to RCPT TO


Troubleshooting so far: I wanted a second pair of eyes on this in real time, so I went down to my local Xfinity store on 5-22 and gave a customer service person the run down. I signed into my account on her computer and duplicated the behavior described above. I also had her send a test message to the primary e-mail from her account, and she received the exact same bounce reply. She double-checked that my account settings were correct, that there is a e-mail address for the account as well as hubby's secondary.  She put in a request to an upper division tech at the time, and called me back the following day to let me know they had reset my e-mail account, please give it a try. No joy. Mailed her back with the sad news that the inaccessibility persists, but have yet to hear back.


New developments:  as of 6-9, my hubby was able to get his address functioning via a POP account (he couldn't get IMAP to work) in his client of choice.  Lots of test messages, all successful.  A test message to the problematic primary e-mail from his account yielded the same 5.1.1 bounce message.  He also could access e-mail via the web portal using his specific login credentials.  So my light bulb was to try adding another secondary user to our Comcast account for another e-mail--and bingo!  POP account (kept this variable the same for the experiment) set up in Thunderbird worked as expected, successful messages to and from other e-mail accounts, including hubby's account.  Also able to access e-mail via the web portal with the login credentials for this secondary user account.  One noticeable difference:  when attempting to send a message from this secondary address to the primary address, the Comcast SMTP server doesn't even allow the message to go out before returning a 5.1.1 error in the client.


I've emailed the rep at our local Comcast store with the 6-9 discoveries, still waiting on a response from her end.  And while it appears that both hubby and I have functioning e-mail addresses, I'm hesitant to begin the arduous task of changing my e-mail address wherever needed until there is some explanation regarding the blockage directly linked to the primary address--specifically is it or is it not usable?


Thanks for sticking with this post and all its details.  I'm hoping someone in the community might have an idea as to the root of the problem with our primary address, another brain to work on the conundrum.


Thanks in advance for any suggestions --



Lynnwood, WA