Community Forum

Port Forwarding Issues with XB3 TG1682G

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

New Poster

Port Forwarding Issues with XB3 TG1682G

Hello,

 

I am attempting to port forward using the XB3 TG1682G dual modem and router to a piece of hardware that I have. I have enabled the port forwarding option in the router settings and added a service to the desired port and internal IP address, and I am unable to connect to my device. I ran numerous online port checking tools as well as the Network Utility app supplied by Apple to determine if my desired port was working. The first strange discrepancy that I found was online port checking tools indicate that port that I added to the router settings were open, but when I ran the Network Utility app, it would not discover the open port. 

 

After wrestling with the problem for a few days, I decided to purchase a cheap router from Goodwill to see if the XB3 was the issue. I put the XB3 in bridge mode plugged the $3 Net Gear N600 WNDR3400 in adjusted the Net Gear's settings and tried to log into my piece of hardware. Surprise, I was able to log in! I re-ran the online port checking tools and Network Utility app, and both indicated that the ports that I opened were open unlike when I used the XB3 router. After doing this test, I decided that there must be something wrong with the Comcast modem/router. I went to Comcast replaced the old XB3 with a new one and tried to port forward again. I also called Comcast to see if it was a software issue. The representative said he installed new software that should solve the issue. I got the impression he was just keeping me on the phone to make me feel like he did something. Once again the XB3 won't forward. 

 

My questions are: Are there firewall settings on the XB3 that won't allow me to port forward? I have the firewall at the minimum currently.

Is there a reason the online port checker and the Net Utility app don't return the same open ports?

Does the XB3 block certain ports? Clearly, Comcast doesn't externally of the XB3 because when I used the new router the forwarding worked fine. 

What settings need to be changed to allow me to port forward other than the obvious "Port Forwarding" settings?

 

Thanks for the help everyone. This journey has been a long and tedious one!