Community Forum

Not getting download speed of Blast 250

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Expert

Re: Not getting download speed of Blast 250

@ComcastAmir can fix that for you if you like. Send a PM. Smiley Happy


I am not a Comcast employee, just a moderator. Pls observe Wheaton's Law.
Regular Visitor

Re: Not getting download speed of Blast 250

Thanks nerdburg for the troubleshooting guide.

I found out that my speed tier is at 150 Mbps after using the guide. Looks like my speed tier has never been upgraded.

Official Employee

Re: Not getting download speed of Blast 250

 

Hello kemcarem16, I can certainly look into your account and make sure everything is provisioned correctly. Can you please send me a private message with your full name, street address, and account number by clicking on my name (ComcastAmir) and then "private message me"?

Expert

Re: Not getting download speed of Blast 250

You can do some troubleshooting on your own here: troubleshooting guide. If you would like some input from the community, please post your equipment details and a screenshot of your signal levels and your error/event log.

 

I've asked a Comcast employee to help you. You should expect a reply in this thread. 

 

FYI: They owe you a $20 credit for every tech visit after the first for the same problem.You can also get a credit for your service from the time you first reported the issue until it is resolved.


I am not a Comcast employee, just a moderator. Pls observe Wheaton's Law.
Highlighted
Regular Visitor

Not getting download speed of Blast 250

Hello,

I upgraded my Internet service to Blast 250 a month or so ago, but I am not getting any close to 200 Mbps. The best I have been able to get is 181 Mbps. Upload speed is fine, around 12+ Mbps. I have had chat support re-provision my cable modem, SB6183, a few times, but no improvement. I have also tried to directly connect to the cable modem, and still got the same download speed. I also had technician come out to look at, and he did not see anything wrong with the cable modem/connection/router. Tech mentioned that many areas within the city where I live might not be fully upgraded to take avantage of this Blast package's download speed. I am not sure whether or not that is a fact. Can I please have someone look at my cable modem and see if it's been configured correctly?