Community Forum

No fix for bad upload

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

New Poster

No fix for bad upload

My uplaod speed slows to a crawl randomly, and can stay down for hours at a time. I have now had xfinity send 4 techs to my home, all of whom show me that the problem originates somewhere before the cable even reaches my property. All 3 upload bands show red when taken from the pole across the street from my home. Xfinity support is aware of this, but is unwilling to send anyone who is allowed to even find where the problem is, let alone address the problem. The 3rd tech was supposed to have been a supervisor that would have been able to escalate the issue, but instead, just another tech showed up. What recourse do I have for this lack of customer service?

Expert

Re: No fix for bad upload

As a customer myself, all I can do is escalate this to the forum administrators and see if they can follow-up on it.

 



I am not a Comcast Employee.
I am a fellow customer, volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark the post as best answer!
Official Employee

Re: No fix for bad upload

 

warrengdrum, if there are outside issues causing service problems, let's say spikes in upstream rippling, we'll need to have a maintenance tech schedule to come out to take a look at the drop and the line at the pole. Please send me a private message (Click ComcastKenF and then click Private Message Me) with your phone number, account address, and full name for assistance.