Community Forum

New xFi Advancd Gateway

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Regular Visitor

New xFi Advancd Gateway

Received the new 1GB xFi Advanced Gateway modem and installed after a few attempts. One thingI'm bummed about is that there are only 2 ethernet ports.  Previous modem had 4.  What are my options?  Do I have to buy an ethernet hub or should I go with a network switch (I'll be honest ... not sure I know the difference).  I need additional ethernet ports to plug in my SONOS Boost.

Expert

Re: New xFi Advancd Gateway

You need a gigabit network switch


I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Regular Visitor

Re: New xFi Advancd Gateway

I bought a 8 port network switch through Amazon. It was the TrendNet Greennet Switch, and I was not able to get it to work. My speed dropped from 800 Mbps to 60 when I had it hooked up. I returned to Amazon and now have another brand on the way. Stay tuned. I’ll let you know if I’m able to resolve. Would have been better if Xfinity kept 4 Ethernet ports in back of router like other older models.
Expert

Re: New xFi Advancd Gateway

I have a 5 Port version of that TrendNet switch and it worked perfectly fine with my original XB6 gateway.
Using an 8 port Netgear GS308 switch now with my current XB6-T and it's been solid.

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Silver Problem Solver

Re: New xFi Advancd Gateway


@brice60 wrote:
I bought a 8 port network switch through Amazon. It was the TrendNet Greennet Switch, and I was not able to get it to work. My speed dropped from 800 Mbps to 60 when I had it hooked up. I returned to Amazon and now have another brand on the way. Stay tuned. I’ll let you know if I’m able to resolve. Would have been better if Xfinity kept 4 Ethernet ports in back of router like other older models.

Is the Trendnet a gigabit switch?  Every ethernet device in my residence runs off mine but I don't have gigabit service, which I assume you have.

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Expert

Re: New xFi Advancd Gateway


@RobertWy wrote:


Is the Trendnet a gigabit switch?  


FWIW: http://www.trendnet.com/products/proddetail?prod=515_teg-s80g



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!