Community Forum

New modem, worse speed

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

New Poster

New modem, worse speed

So, I had an older model of the xfinity router about 3 years and have had about 50mbps download speed. the problem was that it would lag out. streaming videos like on hulu would just stop and I would have to reconnect about every 10 minutes. Playing games I would lag so hard that it wasnt even worth trying to play. So I went to the local xfinity store and had them replace it with the new modem, i guess called the xFi.

Plug in the new modem, and when eveything is set-up I did a speed test(this is wired ethernet to desktop by the way). first with the ookla and was telling me I had now a 1mbps speed. tried using the xfinity speedtest and its been giving me anywhere between 3-12mbps. Talked with Rahul on the live chat. he tried resetting the modem and ended up losing the chat due to accidental x-log. second person i talked to on live chat was Panjak, which he tried litterally an hour trying to fix it. updating the setting and restaring the modem again. However at the end the chat was completley disconnected due to I assume a time out. Third time i live chat I talked to Atul which he says

11:50 PM Atul : I have updated the bootfile and fixed the signal strenth power receive level, upstream level, downstream level ,changes will take place with in half an hour and please do not forget to restart the modem and you will feel the difference after that.
11:50 PM Atul : This is the reason you were getting this issue
11:51 PM Atul : But no worries, you won't face this issue again, my words to you"

however its been 2-3 hours now and still im at the same speeds. its at a 6.38mbps download speed (ethernet) and with wifi its 1mbps and will disconnect forcing me to use data via phone. I have the "Internet Plan: Performance Pro Tier
Download Speed: 100Mbps
Upload Speed: 5Mbps"

Just looking for some help!
Diamond Problem Solver