Community Forum

New Xfinity Email

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

New Poster

New Xfinity Email

I have 5 Comcast emails One main email & 4 extras that I use for various things.  I used to be able to get email on all of them until Comcast changed the platform. Now I only get email on my main account.  I also use Mozilla Thunderbird so I know for a fact I am getting emails on the other accounts, but not on the Comcast site.  I was told all my other emails would "migrate" to the new system by December 31st.  That has not happened.  I have called Comcast several times with less than acceptable results.  I should be able to click on one of the other email folders, hit refresh inbox & get the subsidiary emails like I did in the past.  Is anyone else having this issue?

Expert

Re: New Xfinity Email

Can you see the other 4 accounts under "Add mail account"?  If so click on the black arrowhead to the left of them and see if your folders appear for that account.  If you can't see the accounts at all, try re-entering them by clicking on "Add mail account", and follow the prompts.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: New Xfinity Email

I did that weeks ago when this email server started.  Still not getting my other emails on the comcast site.  I am viewing my emails on Thunderbird, at least that works. 

Expert

Re: New Xfinity Email

Do you have the accounts in Thunderbird enabled using POP3 instead of IMAP?  Because if that's the case, T-Bird may be downloading the messages then deleting them from the server, which would account for why they don't appear in the webmail.  There is a setting in T-Bird that you can use to tell it to leave copies on the server.  Better yet------just enable the accounts with IMAP instead.  That way everything is synced.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!