Community Forum

My MacBook Air 2007 with Safari 6.1.1. browser is not supported by Xfinity. Help

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Highlighted
New Poster

My MacBook Air 2007 with Safari 6.1.1. browser is not supported by Xfinity. Help

i keep getting message to change from Safari to another browser, like Chrome, but i get same message.

Expert

Re: My MacBook Air 2007 with Safari 6.1.1. browser is not supported by Xfinity. Help

 

 

You didn't say which version of OS X you are running.  Chrome requires at least Yosemite 10.10  You could look at Firefox, but with an 11-year-old computer that might not work either.

 

See here for more information---------------

 

https://www.xfinity.com/support/articles/xfinity-connect-supported-browsers



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!