Community Forum

Mail on IPad/IPhone won't recognize User Name & Password from Comcast Email account

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Expert

Re: Mail on IPad/IPhone won't recognize User Name & Password from Comcast Email a

Make sure your username and password match CASE exactly, especially your password.  b2@ngel is not the same as B2@ngel.



I am not a Comcast employee; I am just a customer, volunteering my time to help other customers here in the Forums.

If you'd like information about the Expert program, you can find it here.
Regular Visitor

Re: Mail on IPad/IPhone won't recognize User Name & Password from Comcast Email a

Ditto! Exactly describes my situation also!  New iphone...hope someone has found the answer!!

Frequent Visitor

Mail on IPad/IPhone won't recognize User Name & Password from Comcast Email account

I can not get Email on my IPad and IPhone and MacBook Air to connect to my Comcast account.

 

This started on or about 2/19/15, before all worked fine.  I started getting "Can't get mail" from my Comcast account.  I have deleted the account and attempted to Add Account back.

 

As I Add Account I choose other, Add Mail Account, enter my Name, Email, Password, Description.  It attempts to Verify, and returns "Cannot Get Mail, The user name or password for "imap.comcast.net" is incorrect.

 

I have gone to the Comcast web site (comcast.net) and signed in to my account.  To be sure I reset my password so I'm sure I have the one that works on my account.  My user name was confirmed by logging in, I know what Comcast thinks my user name and password are.

 

Now I go back to Add Account and do it all over (10 times or so) with the same result: Cannot Get Mail, the user name or password for "imap.comcast.net" is incorrect.  Where do I go from here???