Community Forum

Lower than advertised speeds.

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Regular Visitor

Lower than advertised speeds.

Hello.
I've had the XFINITY Performance PLUS/BLAST bundle for a while, and usually see speeds around 10mbps down and 4mbps up.

For the last two-three weeks I have been experiencing horrible speeds, making most of the activities I enjoy next to impossible.
Playing an online game and attempting to use VOIP or other audio communications is completely out of the question.

I'm talking less than 1mbps down.

Also.... like a true scumbag company their own speedtest page will not display results that reflect that I'm receiving less than 1mpbs down, instead I get a "oops something went wrong" message.

So I'm forced to use speedtest.net to get my results.

I have attempted to send a reset signal using the my account page, power cycling all of my hardware many different times and have reseated all the cables at least once since the issue began, but I still don't seem to get any results.

Should I even bother talking to them about this?

I feel like every so often they just slash speeds and wait for you to call just to see if you are paying attention/utilizing your connection.

...why even bother explaining to them my situation if they are consciously doing it to customers.



bullshit.png