Community Forum

Loss of Gigabit speed + no resolution + attempt to charge me to fix = Unhappy Customer

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Frequent Visitor

Loss of Gigabit speed + no resolution + attempt to charge me to fix = Unhappy Customer

Recently, the gigabit service I've had for 2 years now started acting up - slow speeds, random downtimes, general trouble. Websites wouldn't load or would load slowly, streaming video services wouldn't work or work intermittently, and smart home devices were slow to control. At first I'd seen reports of Comcast's recent fiber cuts and thought it may have been related to that. But as the days wore on it became obvious that something else was amiss, so I contacted Comcast support via chat. The tech decided that my modem was old and needed to be upgraded. I was skeptical, but whatever - he told me I could pick one up at the Xfinity store. The next day, I head down to Xfinity, get the new modem, bring it home, and install it. Powers on and comes up immediately and after a few configuration tweaks (hello bridge mode, goodbye xfinitywifi public hotspot), I'm up and running. Go to a few websites to confirm I'm online, then go to run a Speedtest. Through both the standalone Speedtest app (macOS) and through Speedtest.xfinity.com (both on a Retina iMac connected via Ethernet to my Google Wifi primary router), it reported that I was consistently only getting 360Mbps down with the new modem whereas I'd always been able to get 940Mbps down with the old modem before the troubles started. Upset, I decide to chat Comcast again since I was now getting less than half of the bandwidth I'm paying for. After chatting for an hour with extremely basic troubleshooting steps (reset the modem, reboot the computer, try a different browsers, etc), we get cut off with no attempt to re-contact me. After the kids were in bed, I thought I'd try to call Comcast instead. The person I spoke with insisted on going through all of the same useless troubleshooting steps before finally saying they'd have to send a tech out to take a look. However, and this is the part that really galls me, she said that, because everything is showing green on their end that they'll have to charge me a $60 fee for the tech to come out. As I told her on the phone, this is absolutely unacceptable. The service that I pay Comcast handsomely for is no longer working correctly and they want to CHARGE me to come fix their problem. She said something about the charge being for a "professional install" which is both insulting and incorrect. Swapping out a modem doesn't require any skill and, regardless, the service WAS professionally installed two years ago. And had been working fine for those two years. Yet she was absolutely unable / unwilling to waive the charge to help keep a long-time customer happy and get my service running again. At this point, I've done all of the legwork and all of the troubleshooting and they want to charge me to get my service back to where it was two weeks ago. I am beyond livid at Comcast and am seriously considering dropping them for AT&T fiber out of sheer exasperation. Comcast, if you're listening, please do something about this and help retain a customer. Otherwise, I'm sure AT&T will be happy to have me.
Expert

Re: Loss of Gigabit speed + no resolution + attempt to charge me to fix = Unhappy Customer

@highfalutintodd

Sorry, it sounds like you got some bad information there. If Comcast sends a tech and the problem is on Comcast's end, there is no charge to you. 

 

Start here: troubleshooting guide. If you still need help, please post a screenshot of your signal levels and your error/event log. Thank you!

 

 

 


I am not an employee.
Highlighted
Official Employee

Re: Loss of Gigabit speed + no resolution + attempt to charge me to fix = Unhappy Customer

 

Hello highfalutintodd, I am more than happy to assist you with clearing up your service issues. To better assist you please send me a private message with your full name, and account number by clicking on my name (ComcastAmir) and then "private message me".

I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark the post as best answer!