Community Forum

Gigabit service very slow

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

New Poster

Gigabit service very slow

For the past few months or so my internet service is very slow. Have a PS4 hardwired into the router/modem that was provided by Comcast for the gig service. PS4 lags very bad and cannot have another device connected to WiFi at the same time let alone multiple devices. Speed tests on the PS4 show 30-40mbps at best. Speed tests on iPhone X show 120mbps at best. Have called Comcast multiple times and there saying everything is fine from there end. Took about 4 phone calls to get a tech out to my house only to be there for 10 minutes saying everything is fine and that no device can get up to 900+ mbps. Tech also checked modem saying it is fine and still the same problem. Modem is in the middle of the house and can barely watch Netflix from iPad in the bedroom 20 feet away. I am paying over $100 a month to have slow internet. Can I get some help or some kind of advice on what to do next?
Expert

Re: Gigabit service very slow

For a test, what speeds do you get with a computer hardwired directly to the router / gateway device with an ethernet cable ?



I am not a Comcast Employee.
I am a fellow customer, volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark the post as best answer!
New Poster

Re: Gigabit service very slow

Had my laptop come up at 180mbps when wired directly to gateway.
Expert

Re: Gigabit service very slow

How about the upload speed?


I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark the post as best answer!
New Poster

Re: Gigabit service very slow

Upload speed on laptop was 3.4 mbps, PS4 was 1.5 and iPhone X was ~7
Expert

Re: Gigabit service very slow

How about hard wired uploads?


I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark the post as best answer!
New Poster

Re: Gigabit service very slow

PS4 was hard wired and upload was 1.0-3.4, didn’t remember the upload on the laptop when it’s hardwired but I know it’s nowhere near the 40ish mbps upload speed.
Expert

Re: Gigabit service very slow


@ wrote:
PS4 was hard wired and upload was 1.0-3.4, didn’t remember the upload on the laptop when it’s hardwired but I know it’s nowhere near the 40ish mbps upload speed.

How do the signals look like? They can be seen at either http://10.0.0.1 or http://192.168.100.1



I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark the post as best answer!