Community Forum

Gigabit Internet = Unable to Stream to Mixer [Possible blocked port/UDP transport issue]

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

New Poster

Gigabit Internet = Unable to Stream to Mixer [Possible blocked port/UDP transport issue]

Hi everyone!

I stream on Mixer - Microsoft's streaming platform.

I recently upgraded to Gigabit internet, after having (what I assumed were) upload speed issues with my Blast package.

 

While on the Blast package, I could stream at an okay 1800 bitrate at 720p 30fps. With my channel growing, I wanted to increase the quality of my stream. However, even after upgrading to Gigabit, I can't stream at any speeds faster than 1800... Frames are constantly dropped, and connections in general to the Mixer ingest server fail.

 

My gut instinct is that this has to do with the ports that are blocked by default by XFinity.
https://www.xfinity.com/support/articles/list-of-blocked-ports

 

Mixer FTL uses UDP transport protocols, while other streaming services like Twitch use TCP. It should be noted that I'm able to stream just fine on Twitch or Mixer RTMP, which is important to note since they both use TCP protocols.

 

Last night I talked to a tech for about 30 minutes with no solid conclusion, and tonight I was on the phone again with another tech for 30 minutes - unfortunately, there wasn't much that he could suggest, besides posting on the forums for visibility.

 

I'm not alone in these issues. I posted about this on the r/mixer reddit, and found several other people that are experiencing the same difficulties. https://www.reddit.com/r/mixer/comments/7l1sb7/xfinity_gigabit_unable_to_stream_ftl

 

Hopefully there is something that can be done to solve this problem.

 

Edit: For clarification, I am connected via Ethernet cable. I've also tried streaming over Wi-Fi as a test, and got the same results. This doesn't appear to be a computer-related issue, as I got the same results when streaming from my streaming computer, gaming computer, and Xbox One X.

Official Employee

Re: Gigabit Internet = Unable to Stream to Mixer [Possible blocked port/UDP transport issue]

Hi driggsy, 

 

I located your account by using the email address you have registered with the Forums, and was able to review your account on the backend. Due to some signal levels and recent troubleshooting that has been completed on your account, I would like to have a tech come out to isolate the premise issues that could be causing your problems. Can you please send me a private message verifying your account information so we can get a tech scheduled? 

 

Please send me a private message verifying following information: 

  • Your first and last name
  • Primary phone number on the account
  • The street address associated with your services
  • Full account number

 

To send a private message click on my name "ComcastChe", then click private message me.


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: Gigabit Internet = Unable to Stream to Mixer [Possible blocked port/UDP transport issue]

I'm having a similar issue, tried ethernet, wireless, different computer. I even contacted Mixer support and provided all my network logs, in the end, they told me it was my ISP's problem.

 

Did you ever get this resolved?

 

EDIT: I went on Xfinity's live chat, and apparently they reconfigured the signal that my modem was getting, that fixed it.