Community Forum

Gateway not assigning IP Address to Wireless Printer

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Frequent Visitor

Gateway not assigning IP Address to Wireless Printer

Have Epson Workforce 840 printer on home network.

Has worked flawlessly for years.

For over a month now, the printer is not being assigned an IP address.

I have the Xfinity ARRIS TG1682 gateway provided by Comcast.

I try all the usual things: reinstall printer driver; remove printer; add printer; power cycle printer; restart PC.

Have tried changing to Static IP (10.0.0.86 was listed at times printer was woking). That did not help.

Sometimes one or more of these procedures gets me running, but I can never repeat it.

What could have changed since it worked all the time? 

 

Silver Problem Solver

Re: Gateway not assigning IP Address to Wireless Printer

I found I had to use my Brother printer setup disk once to get it connected.

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Frequent Visitor

Re: Gateway not assigning IP Address to Wireless Printer

Thanks for replying.

I have the original setup disk for my Epson 840. It is an old version that was not designed for Windows 10.

The driver needed to be updated when I switched to Win 10.

Just for the heck of it, I used the disk and of course it did not help.

Then went to Epson site and got the latest update installed.

Success!

However I've done this before and the "success" does not stay.

 

So, the problem is really not solved.

Thanks anyway.

 

 

Expert

Re: Gateway not assigning IP Address to Wireless Printer

Are you downloading and installing the Drivers and Utilities Package for the correct version of Windows 10 that you have?



I am not a Comcast employee.
I am a fellow customer volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as best answer!
Frequent Visitor

Re: Gateway not assigning IP Address to Wireless Printer

I have used the recommended package for "Windows 10 64 bit (detected)".

"Drivers and Utilities Combo Package"

I have also tried just the Driver alone package.

I have used the rear reset button on ARRIS Gateway.

The printer's LCD screen always shows an invalid IP.

I eventually get it working, but not sure what I did that helps.

Remove and reinstall printer from Control Panel?

Never know. 

Frequent Visitor

Re: Gateway not assigning IP Address to Wireless Printer

Well, after an hour or so after my last post, the printer came on line without my doing anything!

I guess I am being hit with gamma rays or solar flares Smiley Happy