Community Forum

Extremely slow internet speed

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Regular Visitor

Extremely slow internet speed

My plan says I will get up to 10 megabytes per second.  When I do an Xfinity speed test, it says I should be getting 3.5 megabytes per second.  I'm actually getting, confirmed by multiple different programs, about 450 kilobytes per second.  Kilobytes.  I had faster speeds with my last dial up modem.  I contacted tech support and was told that the only problem was an outdated router.  I went to the service center and got a new model.  It did nothing.  Same ridiculously slow speeds. I've followed all the tips on the troubleshooting articles.  I live at a major intersection and five minutes from the service center, so I'm not out in the boondocks.  I'm convinced that Comcast is throttling me, because no one at Comcast will help me.  If anyone had this problem and managed to solve it, please let me know.  Otherwise I'm going to give another company my money.

Expert

Re: Extremely slow internet speed

Start here: troubleshooting guide. If you still need help, please post your equipment details (make/model of your modem/gateway/router) and a screenshot of your signal levels and your error/event log. Thank you!


I am not an employee.