Community Forum

Experiencing Same Problem as Many - Upgraded Gateway But Being Told I Still Need to Upgrade

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Frequent Visitor

Experiencing Same Problem as Many - Upgraded Gateway But Being Told I Still Need to Upgrade

I upgraded my gateway equipment in order to take advantage of the xFi features, but I'm experiencing the same problem as others here are reporting:

 

I installed the gateway, but when I try to go in to xFi through my account, I'm being told I have to upgrade my equipment...which I've already done.

 

The new "upgraded" gateway I received is a Technicolor model DPC3941T (with DOCSIS 3.0 and DS/US 24x4), and it is otherwise functioning properly.

Silver Problem Solver

Re: Experiencing Same Problem as Many - Upgraded Gateway But Being Told I Still Need to Upgrade

Did you activate it?

https://www.xfinity.com/support/internet/activate-xfi-gateway-app/

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Frequent Visitor

Re: Experiencing Same Problem as Many - Upgraded Gateway But Being Told I Still Need to Upgrade

Yes, that’s not the problem.
Frequent Visitor

Re: Experiencing Same Problem as Many - Upgraded Gateway But Being Told I Still Need to Upgrade

Problem seems to have resolved itself; it appears that activation takes 24 hours.