Community Forum

Ethernet won’t connect

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

New Poster

Ethernet won’t connect

Since a recent power outage nothing plugged in to the Ethernet ports on my Comcast TG1682G gateway will connect to the internet. I’ve disconnected and unplugged/reset all the connected devices and done the same for the gateway as well as doing a factory reset for the gateway. The WiFi from the gateway works fine. Please help.
Expert

Re: Ethernet won’t connect

That's a rental, right? Save yourself the aggravation and just call Comcast to swap it for a different one. I've had various devices downed by power spikes and sags over the years, even with surge protectors installed. That's why I connect my sensitive electronics to UPS's nowadays.  


I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: Ethernet won’t connect

Thanks for your reply and advice. I kind of suspected calling Comcast to swap it out would lead to further aggravation but I’ll give it a try. And I think you’re probably right that the device is bad. Thanks again.