Community Forum

Email Problem

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

New Poster

Email Problem

When I access my Comcast email in-box is in a different language now?

I'm currently at work on my computer.

It's no longer in "English"??

Can you change it back to "English"??

When I access my email in-box on my cell phone its in "English" like its suppose to be, weird??

On my computer its a foreign language or my cell phone English?

 

Can you asist?

Ron Sellers (Sellers707)

 

 

Highlighted
New Poster

Re: Email Problem

When composing, go to the ABC icon at the end of the formatting options.  Choose the down arrow and check English.  Hope this helps!

 

Expert

Re: Email Problem


@Sellers707 wrote:

When I access my Comcast email in-box is in a different language now?

I'm currently at work on my computer.

It's no longer in "English"??

Can you change it back to "English"??

When I access my email in-box on my cell phone its in "English" like its suppose to be, weird??

On my computer its a foreign language or my cell phone English?

 

Can you asist?

Ron Sellers (Sellers707)

 

 


Assuming you are in the new email format, on the Inbox page click on the gear icon in the upper-right corner of the page, then on Settings>>>>>>>Basic Settings.  There you will see the option to switch from Spanish to English.  That is the only other language offered.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!