Community Forum

E-Mail page will not open

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Regular Contributor

Re: E-Mail page will not open

Latoque,

 

Appreciate the response and suggestions. After trying everything, I ended up resetting the computer to a earlier time, and that fixed the problem. 

 

Thanks,

Mick 7

Highlighted
Expert

Re: E-Mail page will not open


Try clearing out your browser's cache/browsing history. When you have done that, close out the browser and re-start it in a fresh session.

If that doesn't do it, then try using a different browser and see if you can duplicate the problem that way. If it works OK then you will know the problem probably lies with the first browser. eg: if you are using Internet Explorer, try Chrome or Firefox.

If you are using IE 10 or 11, make sure Compatibility mode is enabled for comcast.net. You will find it in IE under "Tools".

Regular Contributor

E-Mail page will not open

I have used my e-mail today without any issue.  Now when I go to the e-mail the page opens up, darkens, and then opens up a second homepage.  I use Windows 7   IE11 and the regular comcast e-mail program. 

 

Any ideas how to fix?

 

Mick 7