Community Forum

Delay saving to Sent folder, IMAP connection timeout.

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Official Employee

Re: Delay saving to Sent folder, IMAP connection timeout.

closing solved thread

Official Employee

Re: Delay saving to Sent folder, IMAP connection timeout.

Really, we owe you a big thank you.  You delivered a detailed trouble report, and offered to go above and beyond what is expected of a customer.  Those sorts of details are very beneficial when trying to reproduce and isolate an issue, and eventually come up with a solution that benefits all of our users.  Thank you again.

Frequent Visitor

Re: Delay saving to Sent folder, IMAP connection timeout.

I have been testing this for a couple hours now. As far as I can tell, the sessions appear to be behaving as expected. I have not experienced a delayed response since I saw your last message.

 

You have vastly exceeded my wildest expectation in getting this fixed so quickly.

Thank you very much for making this happen

 

John

 

Official Employee

Re: Delay saving to Sent folder, IMAP connection timeout.

Could you confirm the sessions are now behaving as expected?

Official Employee

Re: Delay saving to Sent folder, IMAP connection timeout.

DocBrown,

 

Thank you for the report.  They were able to reproduce this issue with various clients, and we're working toward a resolution.

 

In the IMAP spec, it states there should be an extended timeout compared to other email-related protocols.  While the servers and the client in this case support that, it looks like the load balancers in some cases are terminating these sessions.  So, when a client attempts to reuse the session it believes should exist, it then times out because the LB has terminated the session.

 

Frequent Visitor

Re: Delay saving to Sent folder, IMAP connection timeout.

I eagerly await the results. If they need it, I can capture and send the Wireshark trace or anyother data they might need.

 

Highlighted
Official Employee

Re: Delay saving to Sent folder, IMAP connection timeout.

I've sent this over to the folks that manage those backend pieces, including the IMAP service.  They're attempting to replicate your issue, and ascertain the cause.

Frequent Visitor

Re: Delay saving to Sent folder, IMAP connection timeout.

Thank you very much for your help.

 

Sending the outgoing message via SMTP is working fine. It is the saving to the IMAP Sent folder that is experiencing the delay.

 

I have three email accounts configured and I also see a delay when I click from the inbox on one account to another. I then must wait about 5 minutes without sending or changing inbox for the delay to occur again.

 

Official Employee

Re: Delay saving to Sent folder, IMAP connection timeout.

I want to make sure we understand the issue you're facing and we get the correct team to look. You're saying that it's taking a long time to save to IMAP/Sent, not to deliver the message via SMTP?  Or are both equally slow?

Gold Problem Solver

Re: Delay saving to Sent folder, IMAP connection timeout.

Let's see if I can get a Comcast Moderator to review your posts and help you.

CC



Need Email Help? Please post the following information in your post.
Do you use XfinityConnect? The Full or Lite version?
Do you use an email client? Which one? (Eg; Windows Live mail, Outlook, a smartphone etc.)
Which browser/version do you use? And- have you cleared your browser cache?
Which operating system? XP, Vista, Windows 7, Mac OS X
Details of the problem you are having.




Frequent Visitor

Re: Delay saving to Sent folder, IMAP connection timeout.

I am very interested in hearing if there are other people that are experiencing these delays when using Comcast email on their computer with any client like Thunderbird, Outlook or others, including Mac

 

Thanks,

John

Frequent Visitor

Delay saving to Sent folder, IMAP connection timeout.

Ever since I fired up the Comcast IMAP access to my email accounts, there have been mostly constant instances of it taking a long time to get a response from the Comcast servers. This is most noticeable when I send emails. It takes about 35 seconds for Thunderbird to complete the process to save the email in the Sent folder. I also see it when I click from one inbox to another (I have multiple accounts configured in T sometimes the circular 'wait' icon takes a while to go away. These delays do not occur with GMail or Yahoo.

After some extensive analysis, I think I know what is going wrong. I fired up Wireshark and another utility TCPView where I can see the TCP connections to my system. I'm not an expert on IMAP so I may be misinterpreting things, but here's what I see:

1. I start TB and several connection are established on port 993 to each of the ISP where I have the account configured.
2. If I send an email from the Comcast account now, they are sent with no delay saving to the Sent folder. There is no delay when I click from one inbox to another.
3. After awhile (awhile is somewhere between 2 and 5 minutes), when I send an email it will take 35 seconds to save to the Sent folder.

What I see in Wireshark is:
1. When TB is first started, I see the connection establishment and exchanges of what I assume is the email syncing between TB and the servers.
2. When I send the first email, a connection is opened on the outgoing server and the email is sent. Then communication takes place on one of the open port 993 connections to update the sent folder.
3. After awhile when I send another email, the email is sent as before, but when TB tries to communicate with the server on the open 993 port, Comcast server does not respond and TB retries the transmission 5 times before resetting the connection and opening a new one. When the new connection is established, the TB finishes the save to the sent folder.

When I try the same scenerio on GMail, I don't see the retransmission timeouts. Google responds to the transmissions on the open ports even after a long time without commmunication. On both Yahoo and Google, I do not see connection timeouts and connection resets. But I DO see that on the Comcast connections!!

It appears to me that comcast is silently closing the connections and the delays are caused by TB's retransmission timeouts and the time TB takes to re-establish the connection.

How can I get Comcast to look into this and help solve this very annoying issue?

Any input from anyone knowledgeable about this would help tremedously!!