Community Forum

Certain Devices Connect And Others Don't?

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Regular Visitor

Certain Devices Connect And Others Don't?

Hi.. A little while ago I wrote a post about how when I stay at my bf's apartment near my school I am at the mercy of using my neighbor's public Xfinity WiFi Hotspot that broadcasts from their router. For two months I used this connection on my laptop and tablet with no problem. After it rained one night the connection disappeared for a couple hours and upon coming back I could no longer connect to it with either of my devices. Upon trying to connect I would get the error message 'can't connect to the network.' For over a week I thought the connection was fried until...


My boyfriend tells me his little Samsung tablet is connecting just fine. Also both his PS3 and PS4 connect with no problem. In every room the connection is strong and works great! So...!!!! Why won't my laptop or my own tablet connect? I've tried resetting my network adapter on my laptop to factory settings with no success. I've tried 'netsh into IP reset resetlog.txt' with no luck. I guess my questions are..

1. Could my laptop and tablet not have a strong enough network adapter? Despite being             connected for two months before?

2. Could someone have banned my two devices over a public hotspot? When I took my laptop     outside I was able to connect but it said 'no internet'. As the connection was very weak. I don't   know if I would have been able to connect at all if I was banned.

3. A long time ago I had the opposite problem with a different connection. I could connect to     my laptop but not my PS4. I found out that I had to enter my IP as a static IP in my PS4. It was   very confusing but it got it to work.. Could something like that be happening with my laptop?


Sorry for the very long post.