Xfinity plant
Xfinity globe
Community Forum

Cannot receive emails on my second Comcast user account.

New Poster

Cannot receive emails on my second Comcast user account.

I am not receiving any emails.  This is a secondary user account, I have no problems with my primary email or any of my other secondary accounts.  

 

I am attempting to use the XFinity oline email client, I've tried using multiple different PC's, on completely different LANs, my personal PC's etc.  I've tried using IE and Chrome no difference. 

 

What is funny is that I can send emails, I can edit inbox folders, but inbox email is always blank but yet I see the red notification box with 0 pending new emails.

 

When I attempt to send to this email, I've used work, gmail and other comcast email addresses, they all seem to send without any kickback or error message.  Stumped.

 

Expert

Re: Cannot receive emails on my second Comcast user account.

Sign in to your Primary account and see what permissions are set.


I am not a Comcast employee; I am just a customer, volunteering my time to help other customers here in the Forums.

If you'd like information about the Expert program, you can find it here.
Expert

Re: Cannot receive emails on my second Comcast user account.


Sportfury440 wrote:

I am not receiving any emails.  This is a secondary user account, I have no problems with my primary email or any of my other secondary accounts.  

 

I am attempting to use the XFinity oline email client, I've tried using multiple different PC's, on completely different LANs, my personal PC's etc.  I've tried using IE and Chrome no difference. 

 

What is funny is that I can send emails, I can edit inbox folders, but inbox email is always blank but yet I see the red notification box with 0 pending new emails.

 

When I attempt to send to this email, I've used work, gmail and other comcast email addresses, they all seem to send without any kickback or error message.  Stumped.

 


Check to see if the Safe List is enabled.  From the Inbox page click on the gear icon in the upper right corner, then on Settings>>>>>Advanced Settings.  If the Safe list is turned on, you will only get emails from addresses on that list, and nothing else will get through.  So if it's on, turn it off.