Community Forum

Arris TG852G Modem Firmware issue with Battery Charging and LED not ON

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Diamond Problem Solver

Re: Arris TG852G Modem Firmware issue with Battery Charging and LED not ON

Year old thread that doesn't even belong on this board is now being closed..

New Poster

Re: Arris TG852G Modem Firmware issue with Battery Charging and LED not ON

Not true. I have that exact modem from Arris with the crapy Xfinity software, and the modem DOES NOT REMEMBER the settings after a power failure. I do have the internal battery, but since I don't have phone service with Comcast, it is disabled. There is no internal flash memory, or the Xfinity software does not utilize it.

 

Not using the internal battery during a power outage for WiFi was, I'm sure, a design decission to extend the battery life for the phone. Good idea, but, there SHOULD be a software setting to allow me to make that choice.

 

It is a real PITA.

 

The modem has 120V input, all the other equipment I own uses a 12v input, and I was able to make myself my own simple battery backup system, but I cannot put the Arris modem on that. (more short sightedness)

 

 

Problem Solver

Re: Arris TG852G Modem Firmware issue with Battery Charging and LED not ON

I just wan't to correct one little thing. The battery on the TG862G does provide power to the router side also during a power outage.

 

A few month ago I had a power outage for a few hours. I continued to use my computer because it was running on a UPS. My TG862G continued to operate on its internal battery. After about 30 minutes the router side of the TG862G shut down cutting off the internet. It was probably set up that way to save the remaining battery power for the modem to keep the phone working.

 

The battery is supposed to keep the phone working from 5 to 8 hours during a power outage. This time is greating diminished if I also use the internet during that time. For that reason I do not recommend using it for the internet during a power outage . It is probably better to save the battery for the phone service.

Regular Visitor

Re: Arris TG852G Modem Firmware issue with Battery Charging and LED not ON

Yes, I do have phone service also.I bought new bat
Seems OK now but was doing a charge discharge thing.
We'll see how it goes
Bridge mode now can't tell what battery level is..
Thanks
Authorized Vendor

Re: Arris TG852G Modem Firmware issue with Battery Charging and LED not ON


e_hak1 wrote:

 

since the battey won't help much in this case, do i need to program my router again after a power outage? or call comcast to donload or activate?

 


nope..  your config will be saved on the device so no issues..

-------------------------------------
Network Engineer, IP Engineer, Docsis..; the views expressed on this post are mine and do not necessarily reflect the views of my employer..

Gamer.. Living the dream one catastrophe at a time Smiley Happy ..
Frequent Visitor

Re: Arris TG852G Modem Firmware issue with Battery Charging and LED not ON

3.27.2014 Reply:

Thank You 'Comcast Tuska' for the answer of my Battery Charge issue, You seem to be the only one that knows this. I wonder why that would be, I am sure this problem most likely came up before, Hum.  PLEASE REPLY AND TELL ME WHAT PAGE OF THE' ARRIS TG852G USE GUIDE' IS THIS ON , I MUST HAVE MISSED IT ????   So if I get the Telephone activated the Modem will then Charge my Battery without shutting down.  I though this might be the case.  What About the LED NOT WORKING??. So Then I will Just leave the Battery Out of the Unit until I get Telephone so I don't destroy the Battery if it goes to Zero.  Rechargeable Lithium Batteries do not like to be fully discharged sometime when you try to recover them. Plus it also seems like the Modem has Reboot Issues if the battery Goes to Close to Zero. Maybe the Power Supply Does Not Like the Discharged Battery in it??

 

Again Thank You and Have a Blessed Day!

xcuda

New Poster

Re: Arris TG852G Modem Firmware issue with Battery Charging and LED not ON

 

since the battey won't help much in this case, do i need to program my router again after a power outage? or call comcast to donload or activate?

 

Authorized Vendor

Re: Arris TG852G Modem Firmware issue with Battery Charging and LED not ON

Arris voice equipment (eMTA)and wireless gateway such as the TG852G and TG862G have battery backup to provide continued telephone service during power outages as noted in the Arris users guide. If the eMTA\wireless gateway is not provisioned for voice by Comcast or another MSO the voice side MTA will shut down which including charging of the battery and battery backup.

 

For continued HSD service a UPS will be required.

 

They can reference the TG852G users guide here.

 

http://moto.arrisi.com/support/documentation/user_guides/_docs/TG852G-NA_User_Guide_Standard1-4.pdf

-------------------------------------
Network Engineer, IP Engineer, Docsis..; the views expressed on this post are mine and do not necessarily reflect the views of my employer..

Gamer.. Living the dream one catastrophe at a time Smiley Happy ..
New Poster

Re: Arris TG852G Modem Firmware issue with Battery Charging and LED not ON

I had the exact same issue and my local Xfinity tech support checked into it and emailed me back. here is what he wrote verbatim: 

 

"Okay, so what I am being told regarding this particular modem is that the battery is meant for telephone backup only, and because the modem is provisioned for internet only, the battery won't work. So, it's not a glitch - it's how the modem is provisioned for the services it provides."

New Poster

Re: Arris TG852G Modem Firmware issue with Battery Charging and LED not ON

I had the exact same issue and my local Xfinity tech support checked into it and emailed me back. here is what he wrote verbatim: 

 

"Okay, so what I am being told regarding this particular modem is that the battery is meant for telephone backup only, and because the modem is provisioned for internet only, the battery won't work. So, it's not a glitch - it's how the modem is provisioned for the services it provides."

Regular Visitor

Re: Arris TG852G Modem Firmware issue with Battery Charging and LED not ON

I have the same exact problem. Battery is always discharging it goes up to 50 percent then drops to zero percent lights flashing. Can I fix this please! Nobody Comcast knows anything.
Frequent Visitor

Re: Arris TG852G Modem Firmware issue with Battery Charging and LED not ON

As of 3.12.2014 I still have this issue.   I have called Arris Tech Support and they do not support the software Comcast / Xfinity install's. But Arris did say with their orignal software the LED shoud be on with the battery in and on AC power which it is. When I log onto the modem software the battery level will show charging increase until about 50- 60% even with the LED not on the modem. After the 50-60% point it starts to discharge even though the AC 120vac plug has been on and active the whole time.  I have also contact Comcast / Xfinity about this with No Solution. I Have read on the form about this discharge issue and the same problem I am having. They also believed there is a issue with the updated software from Comcast.  For a test when I can I am going to try the 2 different battery's I have tried to use in my TG852G in my Brother in Law TM722 they take the same Battery. I will do this test to rule out the Battery's, But I Do Not believe the Battery's are the issue when they both do the same thing charge to 50-60% before discharging. I also have a second TG852G unit with the same Comcast firmware that I have done the same tests which is doing the exact same thing. The Battery's I am using are the 4400mah 10-12 hour Battery's.   I also Do Not have Phone service active on my modem. I Just have Internet and the wired / wireless setup.  I also own my modem. I have been informed by Arris that Comcast is responsibile for firmware issue and upgrades as the firmware is not given direct to customer's but downloaded via ethernet to the modem by the service provider (Comcast / Xfinity). As a added question to both Arris and Comcast that they could not answer, is if I do not have Phone service active if the software is shutting down the Battery Charging after a time. Maybe the software guy's can look at the code and enlight me on this as the NEW TG862G has similar firmware code.

 

Thank You for any Help in advance and Have a Blessed Day!

xcuda

Problem Solver

Re: Arris TG852G Modem Firmware issue with Battery Charging and LED not ON

Have you called the 800# and put in a ticket with Tech Support about this matter? Also what do you mean by the battery discharging? Is it doing it while the unit is plugged in and on?
Frequent Visitor

Arris TG852G Modem Firmware issue with Battery Charging and LED not ON

 

I have an  Arris TG852G wireless gateway modem with updated firmware

 eMTA & DOCSIS Software Version: 7.6.59M

Software Image Name: TS070659M_092613_MODEL_852_GW_CT_SIP_PC20

Packet 2.0

 

The Battery LED Now Never Comes ON and the Battery Discharges after time with the new Firmware??

 

ARRIS and COMCAST Software Eng / Techs Need to Fix This Bug with another Firmware update.

 

The LED Used to be on all the time and the Battery Charged Full with old original firmware I think it was 7.4.xxx something.

 

COMCAST / ARRIS please fix this and down load new firmware update via Ethernet.

 

Thanks in Advance and Have a Blessed Day!

 

xcuda

 

--------------------------------------------------------------------------------------

 

NEW UPDATE 3.12.2014

 

As of 3.12.2014 I still have this issue.   I have called Arris Tech Support and they do not support the software Comcast / Xfinity install's. But Arris did say with their original software the LED should be on with the battery in and on AC power which it is. When I log onto the modem software the battery level will show charging increase until about 50- 60% even with the LED not on the modem. After the 50-60% point it starts to discharge even though the AC 120vac plug has been on and active the whole time.  I have also contact Comcast / Xfinity about this with No Solution. I Have read on the form about this discharge issue and the same problem I am having. They also believed there is an issue with the updated software from Comcast.  For a test when I can I am going to try the 2 different battery's I have tried to use in my TG852G in my Brother in Law TM722 they take the same Battery. I will do this test to rule out the Battery's, But I Do Not believe the Battery's are the issue when they both do the same thing charge to 50-60% before discharging. I also have a second TG852G unit with the same Comcast firmware that I have done the same tests which is doing the exact same thing. The Battery's I am using are the 4400mah 10-12 hour Battery's.   I also Do Not have Phone service active on my modem. I Just have Internet and the wired / wireless setup.  I also own my modem. I have been informed by Arris that Comcast is responsible for firmware issue and upgrades as the firmware is not given direct to customer's but downloaded via ethernet to the modem by the service provider (Comcast / Xfinity). As an added question to both Arris and Comcast that they could not answer, is if I do not have Phone service active if the software is shutting down the Battery Charging after a time. Maybe the software guy's can look at the code and enlight me on this as the NEW TG862G has similar firmware code.

 

Thank You for any Help in advance and Have a Blessed Day!

xcuda

 

 

------------------------------------------------

 

3.27.2014 Reply:

Thank You 'Comcast Tuska' for the answer of my Battery Charge issue, You seem to be the only one that knows this. I wonder why that would be, I am sure this problem most likely came up before, Hum.  PLEASE REPLY AND TELL ME WHAT PAGE OF THE' ARRIS TG852G USE GUIDE' IS THIS ON , I MUST HAVE MISSED IT ????   So if I get the Telephone activated the Modem will then Charge my Battery without shutting down.  I though this might be the case.  What About the LED NOT WORKING??. So Then I will Just leave the Battery Out of the Unit until I get Telephone so I don't destroy the Battery if it goes to Zero.  Rechargeable Lithium Batteries do not like to be fully discharged sometime when you try to recover them. Plus it also seems like the Modem has Reboot Issues if the battery Goes to Close to Zero. Maybe the Power Supply Does Not Like the Discharged Battery in it??

 

Again Thank You and Have a Blessed Day!

xcuda