Community Forum

Activation issue on a modem that I have been using for 3 years

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Regular Visitor

Activation issue on a modem that I have been using for 3 years

I have an Arris TM822G modem that I bought 3 years ago from a store on ebay. Near as I remember, after I bought this modem I plugged it into the network (replacing my old modem) and it worked out of the box. I have had a few minor blips with this equipment but all in all it was working. Recently I tried to use a Roku App for accessing Xfinity content with my Roku. When I open the app it gives me an error that says you must be on your Home network for this to work. I AM on my home network. I also have had similar results accessing content on Xfinity Streams. Some of the content is labeled "in-home" and indicates that I can't watch it unless I am on my home network.


In troubleshooting this issue, I noticed that the equipment identified as my modem was NOT the TM822G but an previous modem. I tried to run the troubleshooting on Xfinity's site and it never gets past the "Reset the modem" and the modem never resets. I chatted with Xfinity for an hour that the tech told me that can't activate my modem because it is a "rented" modem. She said if I bring it to our local Xfinity office they might be able to do something about it. Are they just going to also tell me it can't be activated or can they REALLY do something about it? I don't want to bother to pull the modem if there will really be no solution.


Thanks for any information you can provide!