Community Forum

58willkov

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

New Poster

58willkov

Good morning, I still pay 79.95 for high speed on the internet and I still receive low speed, technical support says call for billing and billing says to call technical support.  

 

Gold Problem Solver

Re: 58willkov

Wifi or Ethernet?

If you want to troubleshoot this yourself, please see Connection Troubleshooting Tips. If you still need help, please provide Information Requested for Connection-Related Posts.

If you are using Wifi it's best to switch to an Ethernet cable connection if possible while measuring speed and checking the reliability of your connection to Comcast.

If Comcast can't fix the problem remotely, insist they send a tech out to identify the cause and correct it.

If the tech finds bad coax, splitters, amplifiers, or connections in your home (even if Comcast originally supplied them) you'll probably have to pay for the visit unless you have or sign up for their Service Protection Plan (https://www.xfinity.com/support/account/service-protection-plan/, about $6/mo) and keep it for at least 60 days. If the trouble is due to a faulty Comcast modem, eMTA, gateway device, or anything outside your home, you shouldn't be charged.