Xfinity plant
Xfinity globe
Community Forum

time zone

New Poster

time zone

My phone seems to be set on Mountain Daylite time...but I live in Arizona and should be

set on Mountain Standard Time...or Arizona Standard time. How do I get this fixed?

Official Employee

Re: time zone

 

snowbear1, have you tried unplugging your modem and then rebooting it? 

 

KenF

New Poster

Re: time zone

Sure have Ken....thanks for trying though.

Official Employee

Re: time zone

 

Hi snowbear1, we may need to re-provision your modem so that the phone displays the correct time on it. But first I want to make sure we are on the same page, most phones have a display on it that controls the time zone manually. Have you been through your phone manual to see if you need to manually set the time? Also can you please tell me where the time indicator is that you are referring to that is incorrect, is it on the phone itself? 

New Poster

Re: time zone

Thanks for responding.....now we've got the opposite problem. Daylite savings time started today and our phone

jumped ahead to mountain daylite time. Comcast insists that their system shows me in AZ time and Mountain

Standard time. Cable and internet clocks are fine, just a problem with phone. I manually changed the time to be

correct and after an hour your system over-rode me and put it back on MDT. I'm talking to a level 3 tech guy

tomorrow. He was unable to fix anything today and wants me to buy a new phone and see if I have the same 

problem with the new phone. The screen with incorrect time is on the face of the phone. And want more fun? If

you call the phone and leave a message, it records the correct time of the message. Yesterday it was telling me

an hour behind our real time. So it appears it thought it was pacific time and jumped to mountain on the message

function. Confused yet? Welcome to my world!

New Poster

Re: time zone

I live in Arizona and have the same problem.  I just moved to the new XB6 modem/router and had a tech over the other day for another problem.  As soon the modem was installed the next day all of our phones were an hour off (forward an hour).  According the tech who checked with his supervist this modem does not have the correct software to support Arizona (no daylight savings) and the patch could be 6-8 months out according to the tech.  So, I was told that I would have to live with it being out of sync for now or swich back to the slower modem.  It will be back on the correct time this fall when the time adjusts everywhere else and hopefully gets corrected after that.

Most support at Comcast will deny that there system passes the time to your phone thru your modem.  They are wrong.  Hope that this helps others.