Community Forum

Voice2Go sporadically works

New Poster

Voice2Go sporadically works

When I upgraded my phone to a Galaxy Note8, the Voice2Go feature which worked remarkedly well on my Note3, will only work occasionally.  When I call a Tech, they get it up and running for possibly 3-4 calls, then it stops again.  This has gone on for months and thru MANY conversations with techs.  I have uninstalled, reinstalled over and over.  They always seem to think its something at Comcast's end so wondering why can't they fix it?  I loved the convenience of this as we travel frequently and getting my home calls forwarded was amazing.  You would think if it worked perfectly on an older model phone, it would surely work on a newer one.

Problem Solver

Re: Voice2Go sporadically works

While not familiar myself with the version of the Android operating system that the Note3 would have been running, the Note8 is recent enough to be running one of the latest versions of the Android operating system.  That being said, there are times when newer has more features and enhancements that unintentionally get in the way of things and need a bit of adjustment.

 

The information below is along the lines of some other postings that I have made in the Xfinity Connect App forum under the Mobile Apps grouping. Hopefully some of this will be of help to you.

 

The following instructions are based on how I navigate to these functions on a Google Pixel XL 1st generation phone that is running the most recent version of Android.  You may have some differences, depending upon how much Samsung has changed the navigation when they tweak Android for their devices.  

 

One area that has caused some issues with the newer releases of Android is the addition of the Data Saver feature.  It is a good feature that helps you optionally keep from going over your cell carriers data limits.  On my device, the overall global Data Saver feature can be found by going to Settings at the phone level, selecting Network & Internet, and Data Usage.  On this screen is a setting called Data Saver.  I keep mine turned off as a personal preference but if yours is turned on then this could be a possible cause of your issue. 

 

If you would like to leave it on, then what you have to do is change a setting at the app level.  On my device to make this change, I go to the Settings at the phone level, select Apps & Notifications, and then select the Connect app.  I then select the Data Usage option and make sure the option for Background data which enables usage of mobile data in the background is turned on as well as make sure the Unrestricted Data Usage which allows unrestriced data access when Data Saver is on it turned on as well.  While this does use more cell data when you receive home phone calls while not within a wifi network range, it does allow the app to continue working and receive home phone calls when you get them.

 

The other area that might be an issue for you is in regards to the newer Battery Saver option.  To find at the overall device level if this option is currently turned on or not, go to Settings at the device level and select Battery.  Look for an option called Battery Saver and see if it is turned on or not.  If it is turned on, then at the Settings at the device level select the Apps & Notifications then select the Connect App.  From the screen it takes you to, select Battery.  Make sure the Background Activity option is turned on to allow the app to run in the background when not in use and make sure the Battery Optimization option is not set for optimization.  While this does not allow your device to conserve its battery life to the maximum, it will allow the app to continue working in the background where it can wait and receive your incoming home phone calls.

 

Hope this information helps you out.

 

New Poster

Re: Voice2Go sporadically works

Thanks so much. It's a lot to absorb but I'm certainly going to give all your suggestions the good old try. Appreciate your response greatly.