Community Forum

Can't add nomorobo call to Advanced Forwarding

Regular Visitor

Can't add nomorobo call to Advanced Forwarding

I'm following the instructions on the Nomorob Web site to set up Nomorobo for my Xfinity Voice telephone line.  When I enter the phone number provided by Nomoroby, the name "NOMOROBO" appears briefly in the Advanced Call Forwarding list, but then the following message appears:

 

The number you have entered is not valid. Please try again with a valid telephone number.

 

Anybody have any idea what is going wrong?  This used to work and I really miss Nomorobo.

New Poster

Re: Can't add nomorobo call to Advanced Forwarding

Within hours of establishing service, I started to get robo calls.  On 24 July, I attempted to enable nomorobo.  I get the same message when I attempt to add 202-813-1600 as instructed by the nomorobo website.  After hitting 'add', it briefly adds the number and identifies it as nomorobo and then the message pops up that it isn't a valid number and to try again with a valid number.

New Poster

Re: Can't add nomorobo call to Advanced Forwarding

I have the same issue

New Poster

Re: Can't add nomorobo call to Advanced Forwarding

I contacted customer service via chat and they resolved the issue.  Level 1 help was not helpful.  Next level was able to do something on their end and added 202-813-1600.  Went back to nomorobo website and the service is now enabled.

 

Took over one hour to resolve problem.

Regular Visitor

Re: Can't add nomorobo call to Advanced Forwarding

@TexLonghorn: Whose customer support did you talk to?  XFinity or Nomorobo?  Xfinity still won't accept 202-813-1600 as a new number in my Advanced Call Forwarding list.

 

I ended up hacking around the problem by using a phone number for another carrier.

New Poster

Re: Can't add nomorobo call to Advanced Forwarding

I chatted with xfinity. 


@expoqeteer wrote:

@TexLonghorn: Whose customer support did you talk to?  XFinity or Nomorobo?  Xfinity still won't accept 202-813-1600 as a new number in my Advanced Call Forwarding list.

 

I ended up hacking around the problem by using a phone number for another carrier.