Xfinity plant
Xfinity globe
Community Forum

unable to send emails what to do?

New Poster

unable to send emails what to do?

I can not send emails only recieve them

Regular Visitor

Re: unable to send emails what to do?

Same here.....

New Poster

Re: unable to send emails what to do?

I'm unable to send emails as well -- they sit in the Draft folder and can't be sent from there either.

Regular Visitor

Re: unable to send emails what to do?

I did call Comcast, they stated they're working on the issue which seems to be isolated to the Safari brower.  Oddly, with my Mac, the Comcast outbox also disappeared but the is present on my IPad.  I can send the unsent/drafts from the IPad but not from the Mac- it's a very messy way to send emails.  My Iphone is sending and receiving email but did have to delete the program and add it on again for that to happen.  Comcast isn't Comcastic, its Comspastic!!!!!!

New Poster

Re: unable to send emails what to do?

Not just a Safari problem. Actually works in Safari for me, but I have Java script enabled and that may be your Safari problem. For me it fails to send from Tor Browser. Used to work. The really frustrating thing is that I see no way to resend a draft email once you select or open it. That's just plain stupid. I mean, if it's a draft you presumably at some point want to send it. Honestly the whole new Comsat web interface is kludgy and annoying. The old one was better.

Expert

Re: unable to send emails what to do?


@Godofthunder666 wrote:

Not just a Safari problem. Actually works in Safari for me, but I have Java script enabled and that may be your Safari problem. For me it fails to send from Tor Browser. Used to work. The really frustrating thing is that I see no way to resend a draft email once you select or open it. That's just plain stupid. I mean, if it's a draft you presumably at some point want to send it. Honestly the whole new Comsat web interface is kludgy and annoying. The old one was better.


Because it's a draft, it is assumed [not by me] that at some point you want to edit it.  Once you open the draft email, click on Edit Draft next to Compose and the Send button will appear at the bottom of the email.

 

Also, from your Drafts folder, if you look at the Toolbar, it says "Compose", "Edit Draft", "Copy of", etc.  So, just highlight the draft email and click on Edit Draft.  It does the same thing.


I am not a Comcast employee; I am just a customer, volunteering my time to help other customers here in the Forums.

If you'd like information about the Expert program, you can find it here.
New Poster

Re: unable to send emails what to do?

So it does. Again a non-intuitive spot since most of the other commands apear at the top. But whatever. I do appreciate the tip.

 

Unfortunately hitting send from the Draft box still doesn't actually send the mail. I've also noticed that send no longer works for me in Safari from a desktop. And I have Java script enabled AND just updated JS. I'm glad I'm paying over $200 for this "service". Do they even beta test this stuff befoe they release it?

New Poster

Re: unable to send emails what to do?

I did some more testing. Send works on latest version of Firefox. But not on Safari or Tor Browser. Tor Browser is essentially the Firefox platform. But with a lot of the annoying ads etc blocked. So I'm guessing this is an annoynace deliberatley built into the system by Comcast to try to track people and when you block tracking, it doesn't work. I'm going to try turning off all tracking features in Safari and see if I can then send.

New Poster

Re: unable to send emails what to do?

Message comes back saying “cannot send mail because smtp is wrong address. 

New Poster

Re: unable to send emails what to do?

So. I was correct. It has to do with tracking. If you go into preferences for Safari and for System and enable location services,  then Safari will send an email. So clearly this is Comast tracking you. Taking clues from Facebook....

 

So if you want to use Safari to send emails from Comast it looks like you have to enable location services.

New Poster

Re: unable to send emails what to do?

That's a different issue than the one discussed here. The problem we are having is that the email just disappears and winds up the "Draft" mailbox. It never gets sent. Usually when you send an eamil, a small pop up window will transiently appear saying "email sent". That doesn't happen. In the current scenario. You get no warning that you're email wasn't sent. So if you weren't paying attention, you don't know it wasn't sent. You don't get the kind of warning you're getting.

 

Are sending from a web browser program or a Mail app?

Expert

Re: unable to send emails what to do?


@Btolomea wrote:

Message comes back saying “cannot send mail because smtp is wrong address. 


Is this in webmail, on your phone, in an email client on your laptop or desktop?  What is the smtp address you have?


I am not a Comcast employee; I am just a customer, volunteering my time to help other customers here in the Forums.

If you'd like information about the Expert program, you can find it here.
New Poster

Re: unable to send emails what to do?

Yes, I installed Firefox and am able to send emails from that browser -- it's inconvenient, though, to have to switch between browsers for different functions.  Thanks for the tip.

 

Can someone post when the Safari issue has been resolved?  Thanks!

New Poster

Re: unable to send emails what to do?

Just to clarify, you can use Safari. You have to enable location services. This of course is an invasion of privacy on the part of comcast, but I'm betting Firefox does it and doesn't even tell you it's doing it. If you want to use Safari, try the following:

In Safai, open Preferences (its under The word Safari in the upper toolbar). Click on the Privacy icon. Select one of the 2 "Prompt for... " radio buttons (I'm guessing right now "Deny without prompting" is on for you.) If you don't have Location Services turned on under System Preferences, a dialog box will open asking if you want to turn on and providing a radio button to Open Security & Privacy Preferences. Click on it. The Security & Privacy Preference panel should open. You may have to unlock the system, if you don't have administrator priveleges, to make the change. Click on "Enable Location Services" and then select "Safari" below it. Close all appropriate windows. You now should be able to send email thru the Comcast web portal.

 

Frankly I find this all rather disgusting. Considering how much we pay Comcast for this service, and that they have a virtual monopoly on the internet in many areas, we shouldn't have to be subjected to their tracking us to spam us with ads.