Community Forum

imap.comcast.net not responding

New Poster

imap.comcast.net not responding

For 24 hours I have not received any comcast email on either my Mac Pro or my iPad. Both had been working for years before this problem. Now comcast support tells me it must be my problem because their server checks out OK. So they're trying to tell me that something changed on both my Mac Pro and my iPad at the same time that caused me to get an "unable to connect to imap.comcast.net". I didn't change any configuration. The support girl even had me delete the account on my iPad so I could re-add it "properly". That didn't work because when trying to add the comcast account I got a, you guessed it: "imap.comcast.net is not responding" error message. They still insist it's my fault.

 

Odd that every thing else on the internet works including GMail. I can also get my mail by logging into my two accounts on the comcast website but is that really considered an efficient way to handle email?! 

 

For the time being I'm having my comcast email forwarded to other gmail accounts. At least Google still can handle email.

Silver Problem Solver

Re: imap.comcast.net not responding

There are many reports of a Comcast E-Mail problem.  

Comcast seems to be the last to know.

http://downdetector.com/status/comcast-xfinity

Expert

Re: imap.comcast.net not responding


@BillMutch wrote:

For 24 hours I have not received any comcast email on either my Mac Pro or my iPad. Both had been working for years before this problem. Now comcast support tells me it must be my problem because their server checks out OK. So they're trying to tell me that something changed on both my Mac Pro and my iPad at the same time that caused me to get an "unable to connect to imap.comcast.net". I didn't change any configuration. The support girl even had me delete the account on my iPad so I could re-add it "properly". That didn't work because when trying to add the comcast account I got a, you guessed it: "imap.comcast.net is not responding" error message. They still insist it's my fault.

 

Odd that every thing else on the internet works including GMail. I can also get my mail by logging into my two accounts on the comcast website but is that really considered an efficient way to handle email?! 

 

For the time being I'm having my comcast email forwarded to other gmail accounts. At least Google still can handle email.


Try changing to imap.email.comcast.net


I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: imap.comcast.net not responding

I’ve got the same problem- it just stopped working and Comcast walked me thru what the settings should be and still no emails!
Expert

Re: imap.comcast.net not responding


wrote:
I’ve got the same problem- it just stopped working and Comcast walked me thru what the settings should be and still no emails!

Try changing the incoming mail server to imap.email.comcast.net .

And check your settings with the below:

 

Incoming server
Server type: IMAP
Server name: imap.email.comcast.net
Connection security: SSL/TLS
Server port: 993
 
Outgoing server
Server name: smtp.comcast.net
Connection security: SSL/TLS
Server port: 465
Authentication: As incoming mail server

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: imap.comcast.net not responding

I've got the same problem.....for 1-2 hours now, can't access my email from either a PC on the comcast.net site nor my phone on the comcast app.  And emails haven't refreshed.  I've rebooted, reconnected my wifi several times.  Nothing has helped.  

Contributor

Re: imap.comcast.net not responding

I cannot get my Xfinity Connect outgoing mail or incoming mail.

I tried to post on the comcast forum, but it asked for me to verify my 

e-mail address and password by sending a verification code to my mailbox.

How can that happen, if I cannot receive mail through their servers.

Contributor

Re: imap.comcast.net not responding

Their email servers are down... its nothing to do with our systems... its all Comcast and they need to fix it.  Seems to be an ongoing problem with their system choking regularly in regions, but this time it is systemwide.

Contributor

Re: imap.comcast.net not responding


wrote:

Their email servers are down... its nothing to do with our systems... its all Comcast and they need to fix it.  Seems to be an ongoing problem with their system choking regularly in regions, but this time it is systemwide.

How did you find that out....???.... 

I called and the lady said check all my connections etc.

I climbed on the roof and through the attic, and checked all the cable connects.

I found one that looked rusty, and I send my wife to home depot to buy new ones.

I cleaned it with sand cloth, and connected it together. 

I reset all boxes and all computers, and no mail working. 

 


 

New Poster

Re: imap.comcast.net not responding

Arrived in Hong Kong and was able to get email.

2 days later I started to get message when I tried accessing email that the "imap.comcast.net"

cannot respond for some reason.  How exactly do you fix this?

Highlighted
Expert

Re: imap.comcast.net not responding


@cagnw wrote:

Arrived in Hong Kong and was able to get email.

2 days later I started to get message when I tried accessing email that the "imap.comcast.net"

cannot respond for some reason.  How exactly do you fix this?


As a temporary fix try using imap.email.comcast.net


I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: imap.comcast.net not responding

So I have tried changing the the name from “imap.comcast.net” to the suggested “ imap.email.comcast.net”. My email still doesn’t work.  Why every few years does this happen? Everything is working fine then all of a sudden email no longer works for no reason or warning. It sure would be nice if Comcast could get their act together and be more compatible. I would like a resolution to this issue. 

New Poster

Re: imap.comcast.net not responding

No longer receiving email via Comcast on my iPhone. Was working fine last night.  Have deleted and re-entered my account and all of the other recommendations from this forum.  Comcast are the most unresponsive company I have ever had the misfortune to have a service with.   Does anyone from Comcast actually monitor this forum?

New Poster

Re: imap.comcast.net not responding

That doesn't work either

New Poster

Re: imap.comcast.net not responding

I changed it on my wife's iPhone from IMAP.Comcast.net to IMAP.email.Comcast.net, and it worked. thank you.

New Poster

Re: imap.comcast.net not responding

When I change to imap.email.comcast.net it then tells me my password doesn’t work?
Expert

Re: imap.comcast.net not responding


@Kski wrote:
When I change to imap.email.comcast.net it then tells me my password doesn’t work?

How are you accessing your email?  Using a desktop client like Outlook or Thunderbird, or with the Mail app on a mobile device or what?



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: imap.comcast.net not responding

Thank you SO much.  I thought I had tried everything! The imap.email.comcast.net worked!!!!!!!!

Regular Visitor

Re: imap.comcast.net not responding

I tried these setting and still no emails.

New Poster

Re: imap.comcast.net not responding

If you are having this issue it's because the imap.comcast.net server is not resolving, they must be having a DNS issues somewhere.  You can confirm this by going to a command prompt and typing "ping imap.comcast.net" (without the quotes) and it will say there is a problem resolving that name.  I got around it using the IP address 96.118.208.96 as the server name so the mail client hits that server directly.  However this isn't a good solution as IP addresses change.  You can use "nslookup imap.comcast.net" for a list of other IP addresses if this one doesn't work for you.  

 

Dear comcast, this is a serious issue and needs attention ASAP.  

New Poster

Re: imap.comcast.net not responding

A few days ago, like others posting here, my email client stoped receiving comsast messages.  Ironically, I could continue to send messages using the comcast account, but could only read messages through the web portal.  Thanks to mightdavefish, I did a nslookup for the imap address and found comcast had changed the server name to imap.ge.xfinity.com. I used that address with port 143 and voila, my email client how is back online.

Frequent Visitor

Re: imap.comcast.net not responding

I can not even get to imap.ge.xfinity.com.

 

New Poster

Re: imap.comcast.net not responding

What email client are you using?

Regular Visitor

Re: imap.comcast.net not responding

I'm using thunderbird on a linux machine and got mine working using after being done for several days:

     imap.ge.xfinity.com      port: 993     ssl/tls     normal password

    smtp.g.comcast.net     port: 465      ssl/tls     normal password

New Poster

Re: imap.comcast.net not responding

My Linux host stopped receiving email on the 28th, though my phone has no problem retrieving it.  I see about half of what's going on, but not the whole story.

 

If I try to ping imap.comcast.net, I get "Name or service not known"; in other words, ping can't even figure out the IP address of the host.  Running something like telnet produces similar results, so there's no surprise that my email client can't resolve the name either.

 

However, if I run "nslookup imap.email.comcast.net", it tells me that imap.email.comcast.net is a CNAME record for imap.ge.xfinity.com, and lists multiple IP addresses for the latter (for the deeply technical, the response also shows that it's querying my systemd-resolved server on my host at 127.0.0.53).

 

This means that DNS can figure it out, but that programs like "ping" and my email client (Thunderbird) aren't getting their answer from DNS.  Comcast can't change how my software looks for those names; all it can do is put the right answer into DNS, and it appears that it has done this.

 

New Poster

Re: imap.comcast.net not responding

And I was just able to fix my own problem.  I use Ubuntu Linux, so I found a bug report at https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1647031.  In my case, I had to install libnss-resolve and that fixed things.

 

For the vast majority of you running something that isn't Ubuntu Linux, that means that, if your email can't resolve imap.comcast.net and you can't ping it,  but you can nslookup it (I think that nslookup is available at the command line for both Windows and Mac), you've got a local resolver problem.  Not sure if this helps anybody, but it's what I know.

 

Silver Problem Solver

Re: imap.comcast.net not responding

I don't know if Comcast made a recent fix, but on my Win10 computer, trying to ping imap.comcast.net shows it pinging imap.ge.xfinity.com instead. It doesn't respond to pings, but it at least resolves to something.

 

Microsoft Windows [Version 10.0.17134.441]
(c) 2018 Microsoft Corporation. All rights reserved.

c:\downloads>ping imap.comcast.net

Pinging imap.ge.xfinity.com [2001:558:fc11:2:f816:3eff:fec7:cb93] with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 2001:558:fc11:2:f816:3eff:fec7:cb93:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

c:\downloads>ping -4 imap.comcast.net

Pinging imap.ge.xfinity.com [96.118.208.89] with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 96.118.208.89:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

 

Frequent Visitor

Re: imap.comcast.net not responding

I have the same problem since November 17.  ping and tracert does not get to the server.

 

New Poster

Re: imap.comcast.net not responding

 I can't ping that host either, though I can receive email.  I suspect that it is configured not to respond to pings.  That doesn't mean that it's down, however.

The good news is that you're getting valid IPs for the name.  If things are working, you should be able to:

telnet port 993, and have it close the connection the first time you hit the <ENTER> key.  This means that you connected to the server, but since you don't speak IMAP, it didn't want to talk to you (it should be much friendlier to your email client)

telnet port 12345 and get connection refused.  This means that you can reach the host, but it's not listening on that port.

 

If the above are true, you can connect to your imap server, but something else is the problem; perhaps your client is misconfigured, and comcast themselves should be experts on setting up most email clients.  If you get a connection refused talking to port 993, I don't know what that means.  If you try to connect to port 993 and it waits a few minutes before timing out, then something is either dropping your request or Comcast's response.  Firewalls and routers are normally configured to only allow traffic on certain ports and drop all requests/responses on other ports, so if you time out, suspect that you have one or the other not programmed to allow port 993 access.

 

New Poster

Re: imap.comcast.net not responding

By reseting to imap.ge.xfinity.com all my email is now available.

But the security certificate is not owned by this site. So you will need to accept the security execption.

Frequent Visitor

Re: imap.comcast.net not responding

I can not do a tracert (Trace Route) to the site, so it is more that the site does not respond to pings.

New Poster

Re: imap.comcast.net not responding

Got it working with imap.ge.xfinity.com, and confirming the security exception, as well...

 

Nice of them to let us know...

Regular Visitor

Re: imap.comcast.net not responding

libnss-resolve also worked for Linux Mint. TNX!

Regular Visitor

Re: imap.comcast.net not responding

I'm runnng Thunderbird on Ubuntu 18.04 and encountered this issue starting on Friday, November 30, 2018. Prior to that, Thunderbird worked fine. I've been in contact with Comcast Support over two hours on this at various times. I even brought up using the imap.ge.xfinity.com server, but agents seemed puzzled by that. As well, they seemed puzzled about using other than Outlook. BTW, usingimap.ge.xfinity.com server works, but I didn't like the idea of not having acertificat for port 143. At any rate, after working with support with several attempts at completng the server, port, and authentation. I concluded that it is a Thunderbird-Ubuntu issue. I confirmed by setting up an Ubuntu VM on a Windows host and encountered the same issues as with my Ubuntu machine. I chose to install libnss-resolve. Installing libnss-resolve fixed the problem. I would like to see the bug to determine why the problem occurred when it did. I'll check further. 

 

Thanks for the solution!

Frequent Visitor

Re: imap.comcast.net not responding

Installing libnss-resolve worked for me.  I had been trying everything for days.  Debian 9.5.0 64-bit, Thunderbird.

New Poster

Re: imap.comcast.net not responding

Can someone walk me through this? Same issue - can't resolve imap.ge.xfinity.com, telnet returns Temporary failure. But I try
 sudo apt-get install  libnss-resolve

and I'm told I have the latest (231-9ubuntu5). (I'm on ubuntu 16.10, maybe I need to reinstall the whole OS?)

 

Very frustrated with comcast. They were absolutely no help. I've been down for a week now.

 

Frequent Visitor

Re: imap.comcast.net not responding

No, don't reinstall the whole OS, becuase that will give you an installation with the minimum default installed utilities and likely will result in even more missing utilities.

 

I solved that problem under Debian 9.5.0, which is likely a little different from your Ubunto 16.10, which is likely based on a little eariler relase of Debian.  Make sure that you have nss-resolve installed too.  Then, start by looking at the results of an nslookup command.  If you don't have nslookup installed, it's in libnet-nslookup-perl.  You should get a long list of alternate servers, such as

Non-authoritative answer:
imap.comcast.net        canonical name = imap.ge.xfinity.com.
Name:   imap.ge.xfinity.com
Address: 96.117.3.201
Name:   imap.ge.xfinity.com
Address: 96.117.3.136

...

If you do get that list, the problem may be in your firewall or a SPAM blocker or some such.  Perform an attempt at setting up a Thunderbird (or other email package) account using imap.comcast.net and then immediately look at your system logs and see what's happening.

 

If you don't get that list, check for these packages that you have these packages (that use nss-resolve):  libc6, libselinux1, and systemd.  Try rebooting to make sure that all the newly installed modules have read the changes in their configuration scripts and look at the nslookup results again.

New Poster

Re: imap.comcast.net not responding

It worked!

Regular Visitor

Re: imap.comcast.net not responding

Ditto...Apple products too...Have you found a solution?

Regular Contributor

Re: imap.comcast.net not responding

I had issues sending emails this morning from my mail app on my MacBook Pro. I checked my mail preferences and it said the smtp server for Comcast and Gmail we’re Offline. I called the tech and told her but she said that is not possible or she would know. Low and behold, after about an hour, I tried to send email and it work, so I checked my mail preference and it said comcast and gmail were connect. 

Official Employee

Re: imap.comcast.net not responding

Hello all,

 

We don't support Linux OS, my apologies for the inconvenience but we won't be able to provide any troubleshooting steps. 

 

@centralvirginia - What email program do you use to check your email? MacMail, Outlook, Thunderbird?

 

 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Frequent Visitor

Re: imap.comcast.net not responding

I'm sorry, did someone ask a question about Linux?  There were questions about imap.comcast.net not responding, but not about Linux.

 

It seems that this was a short-lived server or routing outage some months ago.  Thank you for going through old threads and contributing.

Official Employee

Re: imap.comcast.net not responding

@MakingItAllWork - The latest replies were made less than a week. I greatly appreciate your help in this thread, however, several people were complaining about having email issues with the Thunderbird on Linux OS and mentioned that Comcast agents were not able to assist. I explained why they were not able to assist. I also understand that there were an issue with the server, however, some people mention that they have issues with their email clients in general. 

 

If you have any concerns or questions regarding how we engage with customers on our forum - please feel free to reach out to me directly in PM or contact our community manager ComcastJessie. Thank you!


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Regular Visitor

Re: imap.comcast.net not responding

Yes, I did, as did others. As I noted, eventually I found that the issue was with Linux and the ability to resolve the email server address for Comcast (no others, weird). The frustration I had with Comcast phone support is that they kept instructing me how to set up my Thunderbird email client, as if it were the first time I had set up an email client. I provided troublehshooting information to phone support, but they did not have the tools to escalate it further to see if there was something differnt wrong with the server. 

 

So far, in communication with Comcast phone support for other issues, the agents have limited resources and knowledge as well. I know it is anecdotal, but in one case, I was calling about a Comcast server problem involving my Bryant remote thermostat app. The agent abrupty and rudely closed the call saying that Comcast does not work on third-party equipment before I could explain all the symptoms. As it turns out there was a Bryant-wide issue with the Comcast server. The agent must have been having a bad day.

I see,  according to a subsequent post, that Comcast does not support Linux OS. If that is the case, it should be communicated more clearly to set expectations. 

Official Employee

Re: imap.comcast.net not responding

@kennepede - I apologize for your experience with our phone support. Basically, when it comes to any type of third-party equipment - we can't always help. Not because we don't want to - we just only support Comcast owned equipment and services. However, I totally agree that the phone representatives in both cases were supposed to reach out to the higher level techs to confirm if we have any known issues with our servers. 

 

Most of us in the community team came from the advanced technical support. If we don't know an answer - we will find somebody who does. We have several experts (not Comcast employees) and regular contributors who are very knowledgable and helpful - they can assist with multiple issues too. I strongly encourage you to reach out for help or advice to Xfinity Help & Support Forums. 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Frequent Visitor

Re: imap.comcast.net not responding

Sorry, I haven't asked anyone about LInux in this Century.  I do have a Linux machine that I use Thunderbird on, and all my accounts are IMAP on that machine because main, laptop, phone, etc. are the masters of their respective email accounts.   But I never asked any question about Linux or Thunderbird here.  I have noted a couple of outages of imap.comcast.net on this forum, I think.  It's turned out that these outages are usually so brief that nothing is wrong by the time anyone really notices.

 

I'll scroll back and see if anyone asked about Linux on this thread.  I will agree that asking about an OS on a Comcast/Xfinity board is, uh, not thoughtful.

Frequent Visitor

Re: imap.comcast.net not responding

Yes, I checked back and although no one asked for help about LInux, some announced that they were running under Linux.  I found that on some Linux distributions that they don't install some rarely-needed IP utilities that service URLs that map to many, many aliases, as imap.comcast.net does.  And, I did share a solution for that for Ubuntu/Debian that probably works for most if not all other distributions.  So, there was a digression with people sharing solutions, including me, but no one asked Comcast a question about Linux.  And, your disclaimer is entirely appropriate so that people don't get the impression from user-to-user advice that you solicit questions or provide help for anyting other than your own products, i.e. Comcast/Xfinity internet, email, VoIP phone, cable, etc. as services.  As far as I know, the only located-at-the-customer hardware that you service is your own cables, set-top boxes, modems, and anything else you sell or rent with the Comcast or Xfinity trademarks (VoIP modems and phones?).

Official Employee

Re: imap.comcast.net not responding

@MakingItAllWork - I fully understand where you are coming from and I'm sorry if my reply got you confused. As I mentioned, I really appreciate your help in this thread. Not so many people would take time to share a solution that will work for others. Thank you for doing that!


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Frequent Visitor

Re: imap.comcast.net not responding

I'm easily confused, it seems.  It's been a long time since I have heard from this thread, and I didn't recall the excursion into fixes in the underpinnings of Thunderbird, specifically missing IP utilities in fresh or sparse Linux installations.  I should have checked the thread before replying, but it didn't occur to me soon enough that people would essentially highjack the thread with a conversation about Linux geek stuff, and furthermore that I was a major contributor to the highjacking.

 

FWIW, I had the problem with a fresh Linux installation and a new Thunderbird installation.  I found the problem and its solution in a few minutes on a Linux forum.  In the process, I saw this thread in one of the web searches and came here and saw fit to share the solution.

Regular Visitor

Re: imap.comcast.net not responding

Heh, well it appears we can drive a stake in the heart of this thread. :-) No matter what, this is a useful forum to identify symptoms that are common and unique to troubleshoot issues. Thanks very much. Cheers.