Community Forum

Xfinity mobile website will not load using chrome

Most Valued Poster

Xfinity mobile website will not load using chrome

I run win10 and use Chrome as default browser on my desktop. For the last week or so I cannot get to xfinity mobile website directly or from the link on xfinity.com or  from google links. The site loading bar 'scrolls' across the top of the screen  but nothing comes up. There are no error messages....just a blank screen I can get to it using Firefox but its very slow to load.

 

I have cleared cookies, cache and history but still cannot access. No changes have been made to my desktop. I can access it  via WIFI on tablet and phone using Chrome.  

 

 

Sure would love some insight as to why this is happening?

 

Edit: I have looked at chrome settings and don't see anything that could be causing this and its ONLY happening for the mobile part of xfinity. 

 

When the site tries to load .......'phone signal strength' bars flash across the screen and then  WIFI symbol flashes. Both very fast and briefly. I have no clue why!

Problem Solver

Re: Xfinity mobile website will not load using chrome

I use Windows 10 on my Desktop and as of this writing, have NO problem with Chrome accessing Xfinity Mobile link from the My Xfinity web site.  Also, on my Droid Turbo 2 and using Chrome, I have NO problem accessing Xfinity Mobile link from the My.Xfinity web site.

 

Maybe something in Chrome Settings->Advanced might be causing your issue.

Joe V
(not a Comcast employee, just another paying customer)
Most Valued Poster

Re: Xfinity mobile website will not load using chrome


@jav6joev wrote:

I use Windows 10 on my Desktop and as of this writing, have NO problem with Chrome accessing Xfinity Mobile link from the My Xfinity web site.  Also, on my Droid Turbo 2 and using Chrome, I have NO problem accessing Xfinity Mobile link from the My.Xfinity web site.

 

Maybe something in Chrome Settings->Advanced might be causing your issue.


Thanks. I should have added to my post that I had looked at the settings and I don't see  anything that looks like it might be causing this JUST for xfinity.com/mobile

 

Most Valued Poster

Re: Xfinity mobile website will not load using chrome


@jav6joev wrote:

I use Windows 10 on my Desktop and as of this writing, have NO problem with Chrome accessing Xfinity Mobile link from the My Xfinity web site.  Also, on my Droid Turbo 2 and using Chrome, I have NO problem accessing Xfinity Mobile link from the My.Xfinity web site.

 

Maybe something in Chrome Settings->Advanced might be causing your issue.


=

 

WOW.....something is wrong with the email notifications for replies....I am getting email  notification about your reply to me every 3 minutes....6 so far. You only replied once. Just thought I would mention it.

Problem Solver

Re: Xfinity mobile website will not load using chrome

I did POST, then edit several times.  Maybe those EDIT's/RE-POSTS triggered emails.

Joe V
(not a Comcast employee, just another paying customer)
Most Valued Poster

Re: Xfinity mobile website will not load using chrome


@jav6joev wrote:

I did POST, then edit several times.  Maybe those EDIT's/RE-POSTS triggered emails.


Oh my...I tend to edit my posts often too and had no idea edits triggered emails....oops....wonder if this happened due to the recent redesign.

Expert

Re: Xfinity mobile website will not load using chrome

No, it's always been the case, at least for me,  that if a poster edits a previous comment, another notification gets sent out. 

 

As far as the original issue, could be a caching error. Type in

chrome://settings

in the address bar of Chrome, and then scroll down to Clear Browsing Data to clear the cache.

 

 


I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Most Valued Poster

Re: Xfinity mobile website will not load using chrome


@darkangelic wrote:

No, it's always been the case, at least for me,  that if a poster edits a previous comment, another notification gets sent out. 

 

As far as the original issue, could be a caching error. Type in

chrome://settings

in the address bar of Chrome, and then scroll down to Clear Browsing Data to clear the cache.

 ==

I had already cleared the cache and history but did it again but still can't reach xfinity mobile directly, via google link or using link on xfinity.com. I can reach all other parts of xfinity.com. This is so frustrating. I guess I need to call them but that will result in a 'cluster' I fear.

 


 

Expert

Re: Xfinity mobile website will not load using chrome

What about a DNS cache flush


I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Problem Solver

Re: Xfinity mobile website will not load using chrome

Is there any value at looking at the source of the page trying to load or load it in a debugging mode?  Maybe something to do with Java, ActiveX or related? Using Google Chrome's Customize and control Google Chrome (three dots upper right)->More Tools->Developer Tools or CTRL-Shift- i, prior to loading the page might show what is going on or where it is having trouble loading.

Joe V
(not a Comcast employee, just another paying customer)
Most Valued Poster

Re: Xfinity mobile website will not load using chrome


@darkangelic wrote:

What about a DNS cache flush


just did it....still can't reach xfinity.com/mobile. This is utterly ridiculous

Expert

Re: Xfinity mobile website will not load using chrome

Weird. Does Edge or Firefox exhibit the same problem?


I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Most Valued Poster

Re: Xfinity mobile website will not load using chrome


@jav6joev wrote:

Is there any value at looking at the source of the page trying to load or load it in a debugging mode?  Maybe something to do with Java, ActiveX or related? Using Google Chrome's Customize and control Google Chrome (three dots upper right)->More Tools->Developer Tools or CTRL-Shift- i, prior to loading the page might show what is going on or where it is having trouble loading.


==

You guys are really giving me some great  things to try and I really appreciate it. 

 

I opened up the debugging console as you suggested and there are several tabs. I admit I have no clue whatsoever as to what to look for on any tab that might alert me to an issue. Can't even see a way to share what it says because of the number of tabs and content to scroll thru within each tab so capturing it all to show you would be a nightmare.

 

I can reach the mobile site with FF and Edge but not Chrome so I guess I will just have to use on of those when I need to check my mobile bill,etc.  Never had the problem until last week and nothing was changed on the pc.  Seems like such a simple thing but obviously NOT.

Most Valued Poster

Re: Xfinity mobile website will not load using chrome


@darkangelic wrote:

Weird. Does Edge or Firefox exhibit the same problem?


NOPE...they load just fine

 

Expert

Re: Xfinity mobile website will not load using chrome

I don't see anything strange on the mobile site itself. The only other thing I can think of is an Add-On or Browser Extension within Chrome that might have updated or changed somehow. 


I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Most Valued Poster

Re: Xfinity mobile website will not load using chrome


@darkangelic wrote:

I don't see anything strange on the mobile site itself. The only other thing I can think of is an Add-On or Browser Extension within Chrome that might have updated or changed somehow. 


===

Yep I may have to start the add-on and extension search and destroy mission by turning them all off and then turning them on again one by one. I have not added any new ones in a long time but who knows what might have happened. If that doesn't work...I give up and will just use FF when I want to go to mobile site.

Most Valued Poster

Re: Xfinity mobile website will not load using chrome

Nothing I have done has helped a bit. I am sorry that no Comcast Rep thought this issue was  worthy of their assistance. I even tried to reach the site via a billing email link from Mobile but nope.


Thanks again to those who gave me suggestions of things to try.

Most Valued Poster

Re: Xfinity mobile website will not load using chrome

Just wanted to share that all of a sudden today I can reach xfinity mobile webpage with Chrome just fine. Directly or thru Xfinity.com,etc. I try every day and FINALLY! I made no changes and never did find out what was causing the problem and no one from Comcast on these forums ever 'chimed in' with suggestions so I just wanted to say as we used to say in the world of Telco......'trouble came clear'.

Problem Solver

Re: Xfinity mobile website will not load using chrome

I remember that well: 'trouble came clear while testing'...

Too bad someone couldn't compare the previous web page and current web page for changes.  Embedded scripts might have changed as well.

Joe V
(not a Comcast employee, just another paying customer)
New Poster

Re: Xfinity mobile website will not load using chrome

I'm having the same problem with Windows 10 on my HP laptop and using Chrome on my LG V35.  It's ridiculous!