Community Forum

XFINITY Connect requires the latest browser technologies.

New Poster

XFINITY Connect requires the latest browser technologies.

How does one figure out what to do about this Comcast message? XFINITY Connect requires the latest browser technologies. Please update your current browser or try one of the browsers listed below, thank you!
Bronze Problem Solver

Re: XFINITY Connect requires the latest browser technologies.

Which browser are you using?  Is it the latest version?  If not, updating it is a good idea.