Community Forum

Outlook 2016 not receiving email.

Frequent Visitor

Outlook 2016 not receiving email.

Getting very frustrated. I have tried all suggested solutions and still cannot connect outlook 2016 to my comcast email account. This has been going on for days now. I could use some help.

Expert

Re: Outlook 2016 not receiving email.


@nrobert wrote:

Getting very frustrated. I have tried all suggested solutions and still cannot connect outlook 2016 to my comcast email account. This has been going on for days now. I could use some help.


Have you followed the directions found here?


I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Frequent Visitor

Re: Outlook 2016 not receiving email.

I have tried all posts on this forum including this one. No result.

Gold Problem Solver

Re: Outlook 2016 not receiving email.

What happens when you try to fetch mail? Any error messages or codes? The more details you can provide, the better.

Frequent Visitor

Re: Outlook 2016 not receiving email. - solved

Bruce,

I am unfamiliar with the term "fetch" when applied to email. I found out the problem is the server certificate issued to comcast has the primary name "imap.email.comcast.net". This causes a name mismatch security error in outlook.   I did an nslookup and am now presently using the discovered ip address for the server name. It is a shame that a company like comast has to rely on users to solve the problems they create. I should be awarded a refund for a portion of my monthly billing for mental anguish as this has been going on for 2 weeks. I should also get paid a consultant's fee for solving their error. I am now in the process of solving the "unable to validate server certificate error" I get whenever I open outlook 2016.

Highlighted
Gold Problem Solver

Re: Outlook 2016 not receiving email. - solved


@nrobert wrote: ... I found out the problem is the server certificate issued to comcast has the primary name "imap.email.comcast.net". ...

Have you tried using "imap.comcast.net" as the server name as suggested in the link Again posted, and in https://www.xfinity.com/support/articles/email-client-programs-with-xfinity-email? I've been using it for years and have never had any certificate errors.